Kirby CMS has an Arbitrary Method Call via REST API Search and Collection Query Endpoints
CVE-2026-44174GHSA-86rh-h242-j8xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.4.1, 4.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- <= 4.9.0>= 5.0.0, <= 5.4.0
- Fixed in
- 4.9.1, 5.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-86rh-h242-j8xp lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <=5.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-44174: 0.49% estimated exploitation activity in the next 30 days; percentile 41.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects all Kirby sites that might have potential attackers in the group of authenticated Panel users. This vulnerability is of high severity for affected sites and has a high real-world impact. ---- Introduction Arbitrary method call is a type of arbitrary code execution. It is a vulnerability that allows attackers to run any commands or code of the attacker's choice on a target machine or in a target process. Depending on the set of accessible methods, this can lead to disclosure of sensitive information or to unintended and malicious write actions. Affected components Kirby's data model is made up of model objects that are contained in collection objects. These collections can be queried with methods such as $collection-filter(), $collection-sort(), $collection-group(), $collection-pluck() and $collection-findBy(). Each of these methods allows to query the models contained in the collection by any accessible model attribute (field or method). Kirby also…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-86rh-h242-j8xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44174 Advisory: Kirby CMS has an Arbitrary Method Call via REST API Search and Collection Query Endpoints IDs: CVE-2026-44174, GHSA-86rh-h242-j8xp Record: https://patchnext.com/advisories/cve-2026-44174 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.4.1, 4.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected <= 4.9.0; >= 5.0.0, <= 5.4.0; fixed in 4.9.1, 5.4.1 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-86rh-h242-j8xp (GitHub-reviewed advisory GHSA-86rh-h242-j8xp lists affected ranges: Packagist getkirby/cms >=0 =5.0.0 <=5.4.0) Commands are suggestions: review each one before running it.
Loading voting…