Skip to content

← Actionable
High, CVSS 7.5

phpseclib has a CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

CVE-2026-44167GHSA-3qpq-r242-jqj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.52, 2.0.54, 1.0.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpseclib/phpseclib

    Affected
    >= 2.0.0, <= 2.0.53>= 3.0.0, <= 3.0.51>= 0.1.1, <= 1.0.28
    Fixed in
    1.0.29, 3.0.52, 2.0.54

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-44167: 0.20% estimated exploitation activity in the next 30 days; percentile 10.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc) Patches https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc Workarounds No. References https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3qpq-r242-jqj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44167

Advisory: phpseclib has a CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()
IDs: CVE-2026-44167, GHSA-3qpq-r242-jqj7
Record: https://patchnext.com/advisories/cve-2026-44167 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.52, 2.0.54, 1.0.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpseclib/phpseclib: affected >= 2.0.0, <= 2.0.53; >= 3.0.0, <= 3.0.51; >= 0.1.1, <= 1.0.28; fixed in 1.0.29, 3.0.52, 2.0.54

## Suggested inspection (read-only)
- Packagist phpseclib/phpseclib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpseclib/phpseclib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3qpq-r242-jqj7 (GitHub-reviewed advisory GHSA-3qpq-r242-jqj7 lists affected ranges: Packagist phpseclib/phpseclib >=2.0.0 =3.0.0 =0.1.1 <=1.0.28)

Commands are suggestions: review each one before running it.

Loading voting…