Fluentd is Vulnerable to Server-Side Request Forgery (SSRF) via Placeholder Expansion in out_http
CVE-2026-44161GHSA-72f5-rr8c-r6gr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fluentd 1.19.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems fluentd
- Affected
- <= 1.19.2
- Fixed in
- 1.19.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72f5-rr8c-r6gr lists affected ranges: RubyGems fluentd >=0 <=1.19.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L
- EPSS
- CVE-2026-44161: 0.44% estimated exploitation activity in the next 30 days; percentile 38.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The outhttp output plugin allows the use of placeholders (such as ${tag}) in the endpoint configuration parameter. It was discovered that if the placeholder value is derived from untrusted user input, an attacker can maliciously control the destination hostname of the outbound HTTP requests made by Fluentd. Impact This vulnerability allows for a Server-Side Request Forgery (SSRF) attack. An unauthenticated attacker can force the Fluentd node to send HTTP requests to arbitrary internal services. This can lead to unauthorized access to internal APIs, data exfiltration, or the compromise of cloud metadata endpoints (e.g., AWS IMDS 169.254.169.254). Patches v1.19.3 Workarounds If an immediate upgrade is not possible, users are strongly advised to apply the following mitigations: 1. Avoid Dynamic Hostnames Do not use the placeholder in the endpoint parameter as hostname. 2. Restrict Network Access Use firewall rules (e.g., iptables, AWS Security Groups) to block the Fluentd node from…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-72f5-rr8c-r6gr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-44161 Advisory: Fluentd is Vulnerable to Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` IDs: CVE-2026-44161, GHSA-72f5-rr8c-r6gr Record: https://patchnext.com/advisories/cve-2026-44161 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fluentd 1.19.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems fluentd: affected <= 1.19.2; fixed in 1.19.3 ## Suggested inspection (read-only) - RubyGems fluentd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fluentd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72f5-rr8c-r6gr (GitHub-reviewed advisory GHSA-72f5-rr8c-r6gr lists affected ranges: RubyGems fluentd >=0 <=1.19.2) Commands are suggestions: review each one before running it.
Loading voting…