Skip to content

← Actionable
High, CVSS 8.5amended

OpenClaw: MCP loopback owner context is derived from server-issued bearer tokens

CVE-2026-44118GHSA-r6xh-pqhr-v4xh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.4.21
    Fixed in
    2026.4.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44118: 0.14% estimated exploitation activity in the next 30 days; percentile 2.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary MCP loopback owner context is derived from server-issued bearer tokens. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.4.21 - Fixed version: 2026.4.22 Impact The loopback MCP path accepted spoofable owner-context metadata from request headers, which could allow a non-owner loopback client to present itself as owner for owner-gated operations. Fix The MCP loopback runtime now issues separate owner and non-owner bearer tokens and derives senderIsOwner exclusively from which token authenticated the request. The spoofable sender-owner header is no longer emitted or trusted. Fix Commit(s) - 3cb1a56bfc9579a0f2336f9cfa12a8a744332a19 Verification - The fix commit is contained in the public v2026.4.22 tag. - openclaw@2026.4.22 is published on npm and the compiled package contains the fix. - Focused regression coverage for this path passed before publication. OpenClaw thanks @VladimirEliTokarev for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r6xh-pqhr-v4xh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r6xh-pqhr-v4xh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44118

Advisory: OpenClaw: MCP loopback owner context is derived from server-issued bearer tokens
IDs: CVE-2026-44118, GHSA-r6xh-pqhr-v4xh
Record: https://patchnext.com/advisories/cve-2026-44118 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.4.21; fixed in 2026.4.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r6xh-pqhr-v4xh (OSV record GHSA-r6xh-pqhr-v4xh lists affected ranges: npm openclaw >=0 <2026.4.22 (fixed))
- Verified: https://github.com/advisories/GHSA-r6xh-pqhr-v4xh (GitHub-reviewed advisory GHSA-r6xh-pqhr-v4xh lists affected ranges: npm openclaw >=0 <=2026.4.21)

Commands are suggestions: review each one before running it.

Loading voting…