Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenClaw: QMD memory_get restricts reads to canonical or indexed memory paths

CVE-2026-44111GHSA-f934-5rqf-xx47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.4.15
    Fixed in
    2026.4.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44111: 0.23% estimated exploitation activity in the next 30 days; percentile 13.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The QMD backend memoryget read path accepted arbitrary workspace Markdown paths that were inside the workspace but outside the canonical memory locations or indexed QMD result set. Impact When the QMD backend was enabled, a caller with access to memoryget could read arbitrary .md files under the configured workspace root, even when those files were not canonical memory files and had not been returned by QMD search. Severity remains low because exploitation requires access to the memory tool surface and is limited to workspace Markdown files, but it bypassed the intended memory-path policy. Affected versions - Affected: < 2026.4.15 - Patched: 2026.4.15 Fix OpenClaw 2026.4.15 restricts QMD reads to canonical memory paths or previously indexed QMD workspace paths. Workspace containment alone is no longer sufficient. Verified in v2026.4.15: - extensions/memory-core/src/memory/qmd-manager.ts rejects non-default workspace Markdown paths unless they match an indexed QMD workspace…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f934-5rqf-xx47

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-f934-5rqf-xx47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44111

Advisory: OpenClaw: QMD memory_get restricts reads to canonical or indexed memory paths
IDs: CVE-2026-44111, GHSA-f934-5rqf-xx47
Record: https://patchnext.com/advisories/cve-2026-44111 (revision 3, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.4.15; fixed in 2026.4.15

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f934-5rqf-xx47 (OSV record GHSA-f934-5rqf-xx47 lists affected ranges: npm openclaw >=0 <2026.4.15 (fixed))
- Verified: https://github.com/advisories/GHSA-f934-5rqf-xx47 (GitHub-reviewed advisory GHSA-f934-5rqf-xx47 lists affected ranges: npm openclaw >=0 <2026.4.15)

Commands are suggestions: review each one before running it.

Loading voting…