Skip to content

← Actionable
Medium, CVSS 5.5amended

Docling: Potential Path Traversal via LaTeX \includegraphics and \input Commands

CVE-2026-44022GHSA-2j5p-7p5m-cvqr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (docling 2.91.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI docling

    Affected
    >= 2.73.0, < 2.91.0
    Fixed in
    2.91.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-44022: 0.21% estimated exploitation activity in the next 30 days; percentile 10.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The LaTeX backend's handling of \includegraphics, \input, and \include commands lacked path containment validation. Attackers could craft malicious LaTeX documents with path traversal sequences (e.g., ../../../etc/passwd) to: - Read arbitrary files from the file system accessible to the process - Include sensitive files in the converted document output - Potentially access configuration files, credentials, or other sensitive data Patches Fixed in version 2.91.0. The fix implements strict path validation using Path.resolve().isrelativeto() to ensure all resolved paths remain within the base document directory. Attempts to traverse outside the base directory are logged and blocked. Workarounds Avoid processing untrusted LaTeX documents. If processing is necessary, run in a sandboxed environment with restricted file system access. References - Fix release: v2.91.0

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2j5p-7p5m-cvqr

  2. Revision 1 · created ·

    Published from osv record GHSA-2j5p-7p5m-cvqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44022

Advisory: Docling: Potential Path Traversal via LaTeX \includegraphics and \input Commands
IDs: CVE-2026-44022, GHSA-2j5p-7p5m-cvqr
Record: https://patchnext.com/advisories/cve-2026-44022 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: docling 2.91.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI docling: affected >= 2.73.0, < 2.91.0; fixed in 2.91.0

## Suggested inspection (read-only)
- `python -m pip show docling`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on docling.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2j5p-7p5m-cvqr (OSV record GHSA-2j5p-7p5m-cvqr lists affected ranges: PyPI docling >=2.73.0 <2.91.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2j5p-7p5m-cvqr (GitHub-reviewed advisory GHSA-2j5p-7p5m-cvqr lists affected ranges: PyPI docling >=2.73.0 <2.91.0)

Commands are suggestions: review each one before running it.

Loading voting…