Skip to content

← Actionable
High, CVSS 8.1amended

Docling Core: Insufficient validation of image reference URIs

CVE-2026-44019GHSA-j5xp-7m2f-49jv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (docling-core 2.74.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
EPSS
  • CVE-2026-44019: 0.42% estimated exploitation activity in the next 30 days; percentile 36.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In versions = 2.5.0, < 2.74.1, docling-core could allow local file:// image references and accepted inline data: content without a decoded-size limit. In applications that accept untrusted image references, this may allow access to local files readable by the process or excessive memory use from large inline payloads. Patches Patched in docling-core 2.74.1. The fix blocks local file URIs by default and adds a size limit for decoded inline image data. Users should upgrade to: - docling-core = 2.74.1 Workarounds If upgrading is not immediately possible: - reject file: and data: image references from untrusted input - allow only approved local or remote image sources - apply input size and memory limits to processing workers References - Fix release: v2.74.1

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j5xp-7m2f-49jv

  2. Revision 1 · created ·

    Published from osv record GHSA-j5xp-7m2f-49jv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44019

Advisory: Docling Core: Insufficient validation of image reference URIs
IDs: CVE-2026-44019, GHSA-j5xp-7m2f-49jv
Record: https://patchnext.com/advisories/cve-2026-44019 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: docling-core 2.74.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI docling-core: affected >= 2.5.0, < 2.74.1; fixed in 2.74.1

## Suggested inspection (read-only)
- `python -m pip show docling-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on docling-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j5xp-7m2f-49jv (OSV record GHSA-j5xp-7m2f-49jv lists affected ranges: PyPI docling-core >=2.5.0 <2.74.1 (fixed))
- Verified: https://github.com/advisories/GHSA-j5xp-7m2f-49jv (GitHub-reviewed advisory GHSA-j5xp-7m2f-49jv lists affected ranges: PyPI docling-core >=2.5.0 <2.74.1)

Commands are suggestions: review each one before running it.

Loading voting…