Skip to content

← Actionable
Medium, CVSS 5.5amended

Docling: Unsafe Archive Extraction and XML Parsing in METS-GBS Backend

CVE-2026-44018GHSA-r3xg-rg9j-67fv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (docling 2.91.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI docling

    Affected
    >= 2.45.0, < 2.91.0
    Fixed in
    2.91.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-44018: 0.16% estimated exploitation activity in the next 30 days; percentile 5.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The METS-GBS backend's XML parsing and the input document format detection lacked security controls, enabling: - XML External Entity (XXE) attacks to read local files or cause denial of service - Decompression bombs (zip bombs) to exhaust memory and disk space - Unbounded archive extraction consuming system resources An attacker could craft malicious METS-GBS archives that, when processed, could read sensitive files, exhaust system resources, or cause application crashes. Patches Fixed in version 2.91.0. The fix implements: - Secure XML parsing with resolveentities=False, loaddtd=False, and nonetwork=True - Configurable limits: 300 MB total extraction size, 10 MB per file, 1000 member count - Cumulative size tracking across all extractions - Early termination when limits are exceeded - Secure format detection of METS-GBS tar archives with detectmetsgbs() method: maximum file size (10 MB per file), maximum member count (1000 members), and exception handling to gracefully fail…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r3xg-rg9j-67fv

  2. Revision 1 · created ·

    Published from osv record GHSA-r3xg-rg9j-67fv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44018

Advisory: Docling: Unsafe Archive Extraction and XML Parsing in METS-GBS Backend
IDs: CVE-2026-44018, GHSA-r3xg-rg9j-67fv
Record: https://patchnext.com/advisories/cve-2026-44018 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: docling 2.91.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI docling: affected >= 2.45.0, < 2.91.0; fixed in 2.91.0

## Suggested inspection (read-only)
- `python -m pip show docling`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on docling.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r3xg-rg9j-67fv (OSV record GHSA-r3xg-rg9j-67fv lists affected ranges: PyPI docling >=2.45.0 <2.91.0 (fixed))
- Verified: https://github.com/advisories/GHSA-r3xg-rg9j-67fv (GitHub-reviewed advisory GHSA-r3xg-rg9j-67fv lists affected ranges: PyPI docling >=2.45.0 <2.91.0)

Commands are suggestions: review each one before running it.

Loading voting…