Skip to content

← Actionable
High, CVSS 7.1

Craft CMS's Missing Authorization in GraphQL Address Resolver Allows Cross-Scope PII Disclosure

CVE-2026-44010GHSA-gj2p-p9m4-c8gw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.9.18, 4.17.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0, < 5.9.18>= 4.0.0, < 4.17.12
    Fixed in
    5.9.18, 4.17.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-44010: 0.41% estimated exploitation activity in the next 30 days; percentile 35.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The GraphQL Address element resolver (src/gql/resolvers/elements/Address.php) performs no schema scope filtering on top-level queries. A GraphQL API token scoped to a single low-privilege user group can read every address in the system, including addresses belonging to users in groups the token has no authorization to access. This exposes PII, including full names, addresses, organizations, tax IDs, etc. Details Every GraphQL element resolver in Craft CMS applies schema scope filtering via GqlHelper::extractAllowedEntitiesFromSchema() when handling top-level queries, except the Address resolver. The only gate check for addresses is canQueryUsers() (src/gql/queries/Address.php, line 30), which is a binary check. It returns true if the token has access to any user group. Once past this gate, no further filtering is applied. PoC Tested on: CraftCMS 5.9.17 (fresh Docker install, PHP 8.3) Prerequisites: A GraphQL API token with read access to any single user group Environment -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gj2p-p9m4-c8gw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44010

Advisory: Craft CMS's Missing Authorization in GraphQL Address Resolver Allows Cross-Scope PII Disclosure
IDs: CVE-2026-44010, GHSA-gj2p-p9m4-c8gw
Record: https://patchnext.com/advisories/cve-2026-44010 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.9.18, 4.17.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0, < 5.9.18; >= 4.0.0, < 4.17.12; fixed in 5.9.18, 4.17.12

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gj2p-p9m4-c8gw (GitHub-reviewed advisory GHSA-gj2p-p9m4-c8gw lists affected ranges: Packagist craftcms/cms >=5.0.0 =4.0.0 <4.17.12)

Commands are suggestions: review each one before running it.

Loading voting…