Skip to content

← Actionable
Critical, CVSS 10.0amended

vm2: Mutable Proxies for Host Intrinsic Prototypes Allows Sandbox Escape

CVE-2026-44005GHSA-vwrp-x96c-mhwq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    >= 3.9.6, <= 3.10.5
    Fixed in
    3.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:H
EPSS
  • CVE-2026-44005: 0.83% estimated exploitation activity in the next 30 days; percentile 57.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary vm2's bridge exposes mutable proxies for real host-realm intrinsic prototypes and then forwards sandbox writes into the underlying host objects with otherReflectSet() and otherReflectDefineProperty(), which lets attacker-controlled JavaScript running in a default VM or inherited NodeVM mutate shared host Object.prototype, Array.prototype, and Function.prototype from inside the sandbox. Details BaseHandler.apply() unwraps sandbox-controlled receivers and arguments with otherFromThis() / otherFromThisArguments() and then directly invokes the real host function with ret = otherReflectApply(object, context, args), so any default-exposed host function that can surface a prototype getter becomes a prototype-walking primitive (lib/bridge.js:665-676). BaseHandler.get() special-cases proto and returns the host-side descriptor or proxy target prototype, which is enough for the attacker to reuse the host lookupGetter('proto') accessor repeatedly until the walk lands on host…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vwrp-x96c-mhwq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vwrp-x96c-mhwq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vwrp-x96c-mhwq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44005

Advisory: vm2: Mutable Proxies for Host Intrinsic Prototypes Allows Sandbox Escape
IDs: CVE-2026-44005, GHSA-vwrp-x96c-mhwq
Record: https://patchnext.com/advisories/cve-2026-44005 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected >= 3.9.6, <= 3.10.5; fixed in 3.11.0

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vwrp-x96c-mhwq (GitHub-reviewed advisory GHSA-vwrp-x96c-mhwq lists affected ranges: npm vm2 >=3.9.6 <=3.10.5)
- Verified: https://osv.dev/vulnerability/GHSA-vwrp-x96c-mhwq (OSV record GHSA-vwrp-x96c-mhwq lists affected ranges: npm vm2 >=3.9.6 <3.11.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…