vm2 has a NodeVM require.root bypass via symlink traversal that allows sandbox escape
CVE-2026-43998GHSA-cp6g-6699-wx9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- >= 3.10.5, <= 3.10.5
- Fixed in
- 3.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cp6g-6699-wx9c lists affected ranges: npm vm2 >=3.10.5 <3.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cp6g-6699-wx9c lists affected ranges: npm vm2 >=3.10.5 <=3.10.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-43998: 0.72% estimated exploitation activity in the next 30 days; percentile 54.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary NodeVM's require.root path restriction can be bypassed using filesystem symlinks, allowing sandboxed code to load modules from outside the allowed root directory in host context. Because path validation uses path.resolve() (which does not dereference symlinks) but module loading uses Node's native require() (which does), an attacker can load arbitrary host-realm modules and achieve remote code execution. Severity High (CVSS 3.1: 8.5) CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Attack Vector: Network — sandboxed code is typically received from external sources (user-submitted scripts, plugin code) - Attack Complexity: High — requires symlinks inside the allowed root that point outside it; common with pnpm, npm workspaces, and npm link but not guaranteed in all deployments - Privileges Required: Low — attacker needs only the ability to submit code to the sandbox, which is the intended use case - User Interaction: None - Scope: Changed — the vulnerability is in the sandbox…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cp6g-6699-wx9c
- Revision 1 · created ·
Published from osv record GHSA-cp6g-6699-wx9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43998 Advisory: vm2 has a NodeVM require.root bypass via symlink traversal that allows sandbox escape IDs: CVE-2026-43998, GHSA-cp6g-6699-wx9c Record: https://patchnext.com/advisories/cve-2026-43998 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected >= 3.10.5, <= 3.10.5; fixed in 3.11.0 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cp6g-6699-wx9c (OSV record GHSA-cp6g-6699-wx9c lists affected ranges: npm vm2 >=3.10.5 <3.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cp6g-6699-wx9c (GitHub-reviewed advisory GHSA-cp6g-6699-wx9c lists affected ranges: npm vm2 >=3.10.5 <=3.10.5) Commands are suggestions: review each one before running it.
Loading voting…