vm2 Access to Host Object Enables Sandbox Escape
CVE-2026-43997GHSA-47x8-96vw-5wg6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.10.5
- Fixed in
- 3.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-47x8-96vw-5wg6 lists affected ranges: npm vm2 >=0 <=3.10.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-47x8-96vw-5wg6 lists affected ranges: npm vm2 >=0 <3.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-43997: 0.98% estimated exploitation activity in the next 30 days; percentile 62.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary It is possible to obtain the host Object, https://github.com/patriksimek/vm2/commit/ebcfe94ad2f864f0bc35e78cff1d921107cfd160 added some protections, but the implementation is incomplete. Details There are various ways to use the host Object, to escape the sandbox, one example would be using HostObject.getOwnPropertySymbols to obtain Symbol(nodejs.util.inspect.custom) PoC Impact Sandbox Escape - RCE
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-47x8-96vw-5wg6
- Revision 2 · amended ·
Amended from osv record GHSA-47x8-96vw-5wg6
- Revision 1 · created ·
Published from ghsa record GHSA-47x8-96vw-5wg6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43997 Advisory: vm2 Access to Host Object Enables Sandbox Escape IDs: CVE-2026-43997, GHSA-47x8-96vw-5wg6 Record: https://patchnext.com/advisories/cve-2026-43997 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.10.5; fixed in 3.11.0 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-47x8-96vw-5wg6 (GitHub-reviewed advisory GHSA-47x8-96vw-5wg6 lists affected ranges: npm vm2 >=0 <=3.10.5) - Verified: https://osv.dev/vulnerability/GHSA-47x8-96vw-5wg6 (OSV record GHSA-47x8-96vw-5wg6 lists affected ranges: npm vm2 >=0 <3.11.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…