local-deep-research is Vulnerable to HTML Injection via Unescaped User Input in PDF Export (pdf_service.py:_markdown_to_html)
CVE-2026-43979GHSA-fj2m-qvh9-jq4q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (local-deep-research 1.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI local-deep-research
- Affected
- < 1.6.0
- Fixed in
- 1.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fj2m-qvh9-jq4q lists affected ranges: PyPI local-deep-research >=0 <1.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fj2m-qvh9-jq4q lists affected ranges: PyPI local-deep-research >=0 <1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-43979: 0.33% estimated exploitation activity in the next 30 days; percentile 26.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary PDFService.markdowntohtml() constructs an HTML document by interpolating user-controlled values — specifically title (sourced from research.title or research.query) and metadata key-value pairs — directly into an f-string without any HTML escaping. An authenticated attacker can craft a research query containing HTML special characters to inject arbitrary HTML tags into the document processed by WeasyPrint during PDF export. This injection can be chained to trigger a Server-Side Request Forgery (SSRF), bypassing the application's existing SSRF defenses in ssrfvalidator.py. --- Details Vulnerable code: src/localdeepresearch/web/services/pdfservice.py, lines 171–176 Data flow trace: research.query is a string submitted by the user via POST /api/startresearch, stored as-is in the database, and retrieved without any sanitization. When the user triggers POST /api/v1/research/<researchid/export/pdf, this value is embedded unescaped into the HTML document processed by WeasyPrint.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fj2m-qvh9-jq4q
- Revision 1 · created ·
Published from osv record GHSA-fj2m-qvh9-jq4q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43979 Advisory: local-deep-research is Vulnerable to HTML Injection via Unescaped User Input in PDF Export (`pdf_service.py:_markdown_to_html`) IDs: CVE-2026-43979, GHSA-fj2m-qvh9-jq4q Record: https://patchnext.com/advisories/cve-2026-43979 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: local-deep-research 1.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI local-deep-research: affected < 1.6.0; fixed in 1.6.0 ## Suggested inspection (read-only) - `python -m pip show local-deep-research`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on local-deep-research. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fj2m-qvh9-jq4q (OSV record GHSA-fj2m-qvh9-jq4q lists affected ranges: PyPI local-deep-research >=0 <1.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-fj2m-qvh9-jq4q (GitHub-reviewed advisory GHSA-fj2m-qvh9-jq4q lists affected ranges: PyPI local-deep-research >=0 <1.6.0) Commands are suggestions: review each one before running it.
Loading voting…