Skip to content

← Actionable
High, CVSS 8.9amended

FUXA Vulnerable to Unauthenticated Remote Code Execution via Script Test Mode Authorization Bypass

CVE-2026-43947GHSA-rg3m-cfq7-g6h6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuxa-server 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-43947: 0.91% estimated exploitation activity in the next 30 days; percentile 60.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated Remote Code Execution vulnerability exists in FUXA when secureEnabled is set to true. The POST /api/runscript endpoint checks authorization against the stored script's permission by ID, but when test: true is set in the request, it compiles and executes attacker-supplied code instead of the stored script's code. An unauthenticated attacker who knows a valid script ID and name may execute arbitrary code via test mode if at least one server-side script exists and is accessible without restrictive permissions. Script IDs and names can be obtained through the unauthenticated information disclosure in GET /api/project (reported separately). The only prerequisite is that at least one server-side script exists in the project. Details Authorization confused deputy in script execution File: server/runtime/scripts/index.js, lines 86-103 The authorization check looks up the stored script by ID and validates the stored script's permission field: When a script has no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rg3m-cfq7-g6h6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rg3m-cfq7-g6h6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-43947

Advisory: FUXA Vulnerable to Unauthenticated Remote Code Execution via Script Test Mode Authorization Bypass
IDs: CVE-2026-43947, GHSA-rg3m-cfq7-g6h6
Record: https://patchnext.com/advisories/cve-2026-43947 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fuxa-server 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fuxa-server: affected >= 1.3.0, <= 1.3.0; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fuxa-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rg3m-cfq7-g6h6 (OSV record GHSA-rg3m-cfq7-g6h6 lists affected ranges: npm fuxa-server >=1.3.0 <1.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-rg3m-cfq7-g6h6 (GitHub-reviewed advisory GHSA-rg3m-cfq7-g6h6 lists affected ranges: npm fuxa-server >=1.3.0 <=1.3.0)

Commands are suggestions: review each one before running it.

Loading voting…