FUXA has an unauthenticated arbitrary tag value disclosure via /api/getTagValue
CVE-2026-43946GHSA-fwcm-rqvw-j3p7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuxa-server 1.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fuxa-server
- Affected
- >= 1.3.0, <= 1.3.0
- Fixed in
- 1.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fwcm-rqvw-j3p7 lists affected ranges: npm fuxa-server >=1.3.0 <1.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fwcm-rqvw-j3p7 lists affected ranges: npm fuxa-server >=1.3.0 <=1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-43946: 0.57% estimated exploitation activity in the next 30 days; percentile 47.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authorization bypass in the /api/getTagValue endpoint allows unauthenticated access to tag values when the referenced script does not exist.
Details The issue is caused by the combination of these code paths: - server/api/apikeys/verify-api-or-token.js:45 sends requests without x-api-key to authJwt.verifyToken(req, res, next). - server/api/jwt-helper.js:46-64 creates a signed guest token when no x-access-token is provided: if (!token) { token = getGuestToken(); } and then populates req.userId / req.userGroups from that guest token. - server/api/command/index.js:76-105 exposes /api/getTagValue. - server/runtime/scripts/index.js:106-111 returns true when the referenced script does not exist: if (!script) { return true; } As a result, an unauthenticated request reaches /api/getTagValue as guest, and the authorization check is bypassed because isAuthorisedByScriptName() returns true when sourceScriptName is omitted or does not match a real script. The endpoint then returns…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fwcm-rqvw-j3p7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fwcm-rqvw-j3p7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43946 Advisory: FUXA has an unauthenticated arbitrary tag value disclosure via /api/getTagValue IDs: CVE-2026-43946, GHSA-fwcm-rqvw-j3p7 Record: https://patchnext.com/advisories/cve-2026-43946 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fuxa-server 1.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fuxa-server: affected >= 1.3.0, <= 1.3.0; fixed in 1.3.1 ## Suggested inspection (read-only) - `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fuxa-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fwcm-rqvw-j3p7 (OSV record GHSA-fwcm-rqvw-j3p7 lists affected ranges: npm fuxa-server >=1.3.0 <1.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-fwcm-rqvw-j3p7 (GitHub-reviewed advisory GHSA-fwcm-rqvw-j3p7 lists affected ranges: npm fuxa-server >=1.3.0 <=1.3.0) Commands are suggestions: review each one before running it.
Loading voting…