Skip to content

← Actionable
High, CVSS 8.9amended

FUXA Vulnerable to Pre-auth RCE via Path Manipulation & Configuration Injection

CVE-2026-43945GHSA-p69w-mmfv-xrfj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@frangoteam/fuxa 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-43945: 0.84% estimated exploitation activity in the next 30 days; percentile 57.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Pre-auth RCE in FUXA via Logic Bypass Summary A Critical vulnerability chain exists in FUXA (v.1.3.0-2706) that allows an unauthenticated remote attacker to achieve Full Remote Code Execution (RCE) as root. The exploit succeeds even when the platform is configured in its most secure state (Secure Mode Enabled and Node-RED Secure Auth Enabled). Details The vulnerability is a Path Confusion flaw in the authentication middleware. The server uses a substring match on the full URL (including query parameters) to exclude certain paths from authentication. Involved Logic: JavaScript: Proof of Concept A specially crafted request containing manipulated query parameters could bypass authentication checks on protected /nodered/ endpoints. In configurations where Node-RED exposed privileged or command-execution capable nodes, this could lead to remote code execution within the container context. Impact Access Level: Unauthenticated / Remote. Privilege Level: Access to Node-RED administrative…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p69w-mmfv-xrfj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p69w-mmfv-xrfj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-43945

Advisory: FUXA Vulnerable to Pre-auth RCE via Path Manipulation & Configuration Injection
IDs: CVE-2026-43945, GHSA-p69w-mmfv-xrfj
Record: https://patchnext.com/advisories/cve-2026-43945 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @frangoteam/fuxa 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @frangoteam/fuxa: affected >= 1.2.11, < 1.3.1; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls @frangoteam/fuxa --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @frangoteam/fuxa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p69w-mmfv-xrfj (OSV record GHSA-p69w-mmfv-xrfj lists affected ranges: npm @frangoteam/fuxa >=1.2.11 <1.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-p69w-mmfv-xrfj (GitHub-reviewed advisory GHSA-p69w-mmfv-xrfj lists affected ranges: npm @frangoteam/fuxa >=1.2.11 <1.3.1)

Commands are suggestions: review each one before running it.

Loading voting…