Skip to content

← Actionable
Critical, CVSS 9.4amended

Electerm users can run dangrous code through link or command line

CVE-2026-43944GHSA-mpm8-cx2p-626q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electerm 3.8.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electerm

    Affected
    >= 3.0.6, < 3.8.8
    Fixed in
    3.8.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-43944: 0.36% estimated exploitation activity in the next 30 days; percentile 30.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Affected users: electerm installs that accept protocol URLs or CLI options (affected versions listed in the original report). Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. Patches Fixed in version 3.8.8 commits: - https://github.com/electerm/electerm/commit/8a6a17951e96d715f5a231532bbd8303fe208700 - https://github.com/electerm/electerm/commit/a79e06f4a1f0ac6376c3d2411ef4690fa0377742 - https://github.com/electerm/electerm/commit/0599e67069b00e376a2e962649aaad6096e63507 Workarounds - Disable or unregister electerm protocol handlers (Deep Link settings) and avoid clicking electerm:// links. - Do not run electerm with untrusted --opts arguments or open .lnk / .desktop files from untrusted sources. - Restrict which users can launch electerm on shared machines and avoid leaving electerm installed in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-mpm8-cx2p-626q

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-mpm8-cx2p-626q

  4. Revision 1 · created ·

    Published from ghsa record GHSA-mpm8-cx2p-626q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-43944

Advisory: Electerm users can run dangrous code through link or command line
IDs: CVE-2026-43944, GHSA-mpm8-cx2p-626q
Record: https://patchnext.com/advisories/cve-2026-43944 (revision 4, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electerm 3.8.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electerm: affected >= 3.0.6, < 3.8.8; fixed in 3.8.8

## Suggested inspection (read-only)
- `npm ls electerm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electerm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mpm8-cx2p-626q (GitHub-reviewed advisory GHSA-mpm8-cx2p-626q lists affected ranges: npm electerm >=3.0.6 <3.8.8)
- Verified: https://osv.dev/vulnerability/GHSA-mpm8-cx2p-626q (OSV record GHSA-mpm8-cx2p-626q lists affected ranges: npm electerm >=3.0.6 <3.8.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…