Electerm Security Vulnerability: RCE via malicious SSH server filename in openFileWithEditor
CVE-2026-43943GHSA-q4p8-8j9m-8hxj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electerm 3.7.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electerm
- Affected
- <= 3.7.8
- Fixed in
- 3.7.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q4p8-8j9m-8hxj lists affected ranges: npm electerm >=0 <3.7.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4p8-8j9m-8hxj lists affected ranges: npm electerm >=0 <=3.7.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-43943: 0.17% estimated exploitation activity in the next 30 days; percentile 5.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A code execution (RCE) vulnerability exists in electerm's SFTP open with system editor or "Edit with custom editor" feature. When a user opts to edit a file using open with system editor or open with a custom editor, the filename is passed directly into a command line without sanitization. A malicious actor controlling the SSH server or user OS can exploit this by crafting a filename containing shell metacharacters. If a victim subsequently attempts to edit this file, the injected commands are executed on their machine with the user's privileges. This could allow the attacker to run arbitrary code, install malware, or move laterally within the network. <img width="1792" height="817" alt="1" src="https://github.com/user-attachments/assets/ddf78890-e95d-4fe7-981e-f86887677e8b" / <img width="1648" height="941" alt="2" src="https://github.com/user-attachments/assets/cca2295b-2053-4d99-a464-be51eac2f5be" / Patches Fixed in version = 3.7.9 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q4p8-8j9m-8hxj
- Revision 1 · created ·
Published from osv record GHSA-q4p8-8j9m-8hxj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43943 Advisory: Electerm Security Vulnerability: RCE via malicious SSH server filename in openFileWithEditor IDs: CVE-2026-43943, GHSA-q4p8-8j9m-8hxj Record: https://patchnext.com/advisories/cve-2026-43943 (revision 2, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electerm 3.7.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electerm: affected <= 3.7.8; fixed in 3.7.9 ## Suggested inspection (read-only) - `npm ls electerm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electerm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q4p8-8j9m-8hxj (OSV record GHSA-q4p8-8j9m-8hxj lists affected ranges: npm electerm >=0 <3.7.9 (fixed)) - Verified: https://github.com/advisories/GHSA-q4p8-8j9m-8hxj (GitHub-reviewed advisory GHSA-q4p8-8j9m-8hxj lists affected ranges: npm electerm >=0 <=3.7.8) Commands are suggestions: review each one before running it.
Loading voting…