parse-server: MFA SMS one-time password accepted twice under concurrent login
CVE-2026-43930GHSA-jpq4-7fmq-q5fj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.9.0-alpha.2, 8.6.76), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.9.0-alpha.2< 8.6.76
- Fixed in
- 9.9.0-alpha.2, 8.6.76
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jpq4-7fmq-q5fj lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.76 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpq4-7fmq-q5fj lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.76
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-43930: 0.24% estimated exploitation activity in the next 30 days; percentile 14.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A race condition in the MFA SMS one-time password (OTP) login path allows two concurrent /login requests carrying the same OTP to both succeed and both receive valid session tokens, breaking the single-use property of the OTP. The vulnerability requires the attacker to already possess the victim's password and intercept the active SMS OTP (e.g. via SIM swap, network mirror, or phishing relay) and to race the legitimate login request, so the practical attack surface is narrow. This advisory is the same class of incomplete fix as GHSA-2299-ghjr-6vjp (TOTP recovery codes) and GHSA-w73w-g5xw-rwhf (MFA recovery in authData-only login). Those previous fixes added optimistic locking only for array-typed authData fields; SMS MFA stores the OTP as a string, so the guard skipped it. Patches The optimistic lock has been generalized to cover primitive (string, number, boolean) and array authData fields. The lock is implemented as a shared helper applyAuthDataOptimisticLock that adds…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jpq4-7fmq-q5fj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jpq4-7fmq-q5fj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43930 Advisory: parse-server: MFA SMS one-time password accepted twice under concurrent login IDs: CVE-2026-43930, GHSA-jpq4-7fmq-q5fj Record: https://patchnext.com/advisories/cve-2026-43930 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.9.0-alpha.2, 8.6.76. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.9.0-alpha.2; < 8.6.76; fixed in 9.9.0-alpha.2, 8.6.76 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jpq4-7fmq-q5fj (OSV record GHSA-jpq4-7fmq-q5fj lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.76 (fixed)) - Verified: https://github.com/advisories/GHSA-jpq4-7fmq-q5fj (GitHub-reviewed advisory GHSA-jpq4-7fmq-q5fj lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.76) Commands are suggestions: review each one before running it.
Loading voting…