link-preview-js vulnerable to IPv6 and internal loopback attacks
CVE-2026-43897GHSA-4gp8-rjrq-ch6q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (link-preview-js 4.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm link-preview-js
- Affected
- <= 4.0.0
- Fixed in
- 4.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4gp8-rjrq-ch6q lists affected ranges: npm link-preview-js >=0 <4.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4gp8-rjrq-ch6q lists affected ranges: npm link-preview-js >=0 <=4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-43897: 0.65% estimated exploitation activity in the next 30 days; percentile 51.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The library did not check for IPv6 loopback attacks. There was also a DNS attack, where an address could be resolved into an internal IP. This could cause internal data leaks. Patches Problem has been patched in version 4.0.1. However, it cannot be completely solved by the package alone. The regex used for validation has been tightened for IPv6 addresses. The DNS resolving, however, is more difficult. The regex has been tightened to prohibit .internal, .local, .nip.io and .sslip.io addresses, however there can be other services not on the list, therefore it is imperative that users use the resolveDNSHost option to do DNS resolution before fetching content. To that regard a (scary) error message has been added when the option is not set. Workarounds Users can do their own validation before fetching content. Reported by https://github.com/Andrew-most-likely
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4gp8-rjrq-ch6q
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4gp8-rjrq-ch6q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43897 Advisory: link-preview-js vulnerable to IPv6 and internal loopback attacks IDs: CVE-2026-43897, GHSA-4gp8-rjrq-ch6q Record: https://patchnext.com/advisories/cve-2026-43897 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: link-preview-js 4.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm link-preview-js: affected <= 4.0.0; fixed in 4.0.1 ## Suggested inspection (read-only) - `npm ls link-preview-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on link-preview-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4gp8-rjrq-ch6q (OSV record GHSA-4gp8-rjrq-ch6q lists affected ranges: npm link-preview-js >=0 <4.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-4gp8-rjrq-ch6q (GitHub-reviewed advisory GHSA-4gp8-rjrq-ch6q lists affected ranges: npm link-preview-js >=0 <=4.0.0) Commands are suggestions: review each one before running it.
Loading voting…