Apache Camel JMS deserialization filter bypass
CVE-2026-43866GHSA-f755-xp6r-8q84
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-activemq 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-jms 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-sjms 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-activemq6 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-sjms2 4.21.0, 4.18.3, 4.14.8; 1 more package under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.camel:camel-activemq
- Affected
- >= 3.0.0, < 4.14.8>= 4.15.0, < 4.18.3>= 4.19.0, < 4.21.0
- Fixed in
- 4.21.0, 4.14.8, 4.18.3
Maven org.apache.camel:camel-jms
- Affected
- >= 3.0.0, < 4.14.8>= 4.15.0, < 4.18.3>= 4.19.0, < 4.21.0
- Fixed in
- 4.21.0, 4.14.8, 4.18.3
Maven org.apache.camel:camel-sjms
- Affected
- >= 3.0.0, < 4.14.8>= 4.15.0, < 4.18.3>= 4.19.0, < 4.21.0
- Fixed in
- 4.21.0, 4.14.8, 4.18.3
Maven org.apache.camel:camel-activemq6
- Affected
- >= 3.0.0, < 4.14.8>= 4.15.0, < 4.18.3>= 4.19.0, < 4.21.0
- Fixed in
- 4.21.0, 4.14.8, 4.18.3
Maven org.apache.camel:camel-sjms2
- Affected
- >= 3.0.0, < 4.14.8>= 4.15.0, < 4.18.3>= 4.19.0, < 4.21.0
- Fixed in
- 4.21.0, 4.14.8, 4.18.3
Maven org.apache.camel:camel-amqp
- Affected
- >= 3.0.0, < 4.14.8>= 4.15.0, < 4.18.3>= 4.19.0, < 4.21.0
- Fixed in
- 4.21.0, 4.14.8, 4.18.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f755-xp6r-8q84 lists affected ranges: Maven org.apache.camel:camel-jms >=3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-43866: 0.65% estimated exploitation activity in the next 30 days; percentile 51.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Deserialization of Untrusted Data vulnerability in Apache Camel, Apache Camel JMS component. JmsBinding.extractBodyFromJms() in camel-jms - and the equivalent JmsBinding in camel-sjms - deserializes the payload of an incoming JMS ObjectMessage via jakarta.jms.ObjectMessage.getObject() whenever the mapJmsMessage option is enabled (the default) and Camel acts as a JMS consumer. The CVE-2026-40860 hardening added a post-deserialization class check that rejects classes outside the default allow-list java.;javax.;org.apache.camel.;!. However org.apache.camel.support.DefaultExchangeHolder itself lives in the allow-listed org.apache.camel. namespace, so an ObjectMessage whose top-level object is a DefaultExchangeHolder passes the check. The receiving side then calls DefaultExchangeHolder.unmarshal() on it without requiring the transferExchange option to be enabled - an asymmetric trust boundary, since the sending side gates ObjectMessage and transferExchange handling but the receiving side…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f755-xp6r-8q84
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43866 Advisory: Apache Camel JMS deserialization filter bypass IDs: CVE-2026-43866, GHSA-f755-xp6r-8q84 Record: https://patchnext.com/advisories/cve-2026-43866 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-activemq 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-jms 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-sjms 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-activemq6 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-sjms2 4.21.0, 4.18.3, 4.14.8; org.apache.camel:camel-amqp 4.21.0, 4.18.3, 4.14.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.camel:camel-activemq: affected >= 3.0.0, < 4.14.8; >= 4.15.0, < 4.18.3; >= 4.19.0, < 4.21.0; fixed in 4.21.0, 4.14.8, 4.18.3 - Maven org.apache.camel:camel-jms: affected >= 3.0.0, < 4.14.8; >= 4.15.0, < 4.18.3; >= 4.19.0, < 4.21.0; fixed in 4.21.0, 4.14.8, 4.18.3 - Maven org.apache.camel:camel-sjms: affected >= 3.0.0, < 4.14.8; >= 4.15.0, < 4.18.3; >= 4.19.0, < 4.21.0; fixed in 4.21.0, 4.14.8, 4.18.3 - Maven org.apache.camel:camel-activemq6: affected >= 3.0.0, < 4.14.8; >= 4.15.0, < 4.18.3; >= 4.19.0, < 4.21.0; fixed in 4.21.0, 4.14.8, 4.18.3 - Maven org.apache.camel:camel-sjms2: affected >= 3.0.0, < 4.14.8; >= 4.15.0, < 4.18.3; >= 4.19.0, < 4.21.0; fixed in 4.21.0, 4.14.8, 4.18.3 - Maven org.apache.camel:camel-amqp: affected >= 3.0.0, < 4.14.8; >= 4.15.0, < 4.18.3; >= 4.19.0, < 4.21.0; fixed in 4.21.0, 4.14.8, 4.18.3 ## Suggested inspection (read-only) - Maven org.apache.camel:camel-activemq: check the installed version with your package manager. - Maven org.apache.camel:camel-jms: check the installed version with your package manager. - Maven org.apache.camel:camel-sjms: check the installed version with your package manager. - Maven org.apache.camel:camel-activemq6: check the installed version with your package manager. - Maven org.apache.camel:camel-sjms2: check the installed version with your package manager. - Maven org.apache.camel:camel-amqp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.camel:camel-activemq, org.apache.camel:camel-jms, org.apache.camel:camel-sjms, org.apache.camel:camel-activemq6, org.apache.camel:camel-sjms2, org.apache.camel:camel-amqp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f755-xp6r-8q84 (GitHub-reviewed advisory GHSA-f755-xp6r-8q84 lists affected ranges: Maven org.apache.camel:camel-jms >=3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0…) Commands are suggestions: review each one before running it.
Loading voting…