HuggingFace transformers vulnerable to remote code execution
CVE-2026-4372GHSA-29pf-2h5f-8g72
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (transformers 5.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI transformers
- Affected
- < 5.3.0
- Fixed in
- 5.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-29pf-2h5f-8g72 lists affected ranges: PyPI transformers >=0 <5.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-29pf-2h5f-8g72 lists affected ranges: PyPI transformers >=0 <5.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-4372: 0.70% estimated exploitation activity in the next 30 days; percentile 53.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A critical remote code execution vulnerability exists in all versions of the HuggingFace transformers library prior to version 5.3.0. The vulnerability allows an attacker to craft a malicious config.json file containing the attnimplementationinternal field set to an attacker-controlled HuggingFace Hub repository ID. When a victim loads this model using the standard AutoModelForCausalLM.frompretrained() API, the library downloads and executes arbitrary Python code from the attacker's repository with the victim's full OS privileges. This issue arises due to unfiltered deserialization of configuration attributes, insufficient sanitization of internal fields, and unsandboxed execution of downloaded kernels. The vulnerability bypasses the trustremotecode security mechanism, is invisible to the victim, and exploits the standard documented usage pattern, making it particularly severe. Users are advised to upgrade to version 5.3.0 or later to mitigate this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-29pf-2h5f-8g72
- Revision 1 · created ·
Published from osv record GHSA-29pf-2h5f-8g72
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-4372 Advisory: HuggingFace transformers vulnerable to remote code execution IDs: CVE-2026-4372, GHSA-29pf-2h5f-8g72 Record: https://patchnext.com/advisories/cve-2026-4372 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: transformers 5.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI transformers: affected < 5.3.0; fixed in 5.3.0 ## Suggested inspection (read-only) - `python -m pip show transformers`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on transformers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-29pf-2h5f-8g72 (OSV record GHSA-29pf-2h5f-8g72 lists affected ranges: PyPI transformers >=0 <5.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-29pf-2h5f-8g72 (GitHub-reviewed advisory GHSA-29pf-2h5f-8g72 lists affected ranges: PyPI transformers >=0 <5.3.0) Commands are suggestions: review each one before running it.
Loading voting…