Skip to content

← Actionable
High, CVSS 7.5

Apache Wicket has an Exposure of Sensitive Information to an Unauthorized Actor vulnerability

CVE-2026-43646GHSA-jvv4-8wxx-m5r6

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-43646: 0.39% estimated exploitation activity in the next 30 days; percentile 33.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jvv4-8wxx-m5r6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-43646

Advisory: Apache Wicket has an Exposure of Sensitive Information to an Unauthorized Actor vulnerability
IDs: CVE-2026-43646, GHSA-jvv4-8wxx-m5r6
Record: https://patchnext.com/advisories/cve-2026-43646 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.wicket:wicket-parent 10.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.wicket:wicket-parent: affected >= 8.0.0-M1, <= 8.17.0; >= 9.0.0-M1, <= 9.22.0; >= 10.0.0-M1, <= 10.8.0; fixed in 10.9.0

## Suggested inspection (read-only)
- Maven org.apache.wicket:wicket-parent: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.wicket:wicket-parent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jvv4-8wxx-m5r6 (GitHub-reviewed advisory GHSA-jvv4-8wxx-m5r6 lists affected ranges: Maven org.apache.wicket:wicket-parent >=8.0.0-M1 =9.0.0-M1 =10.0.0-M1 <=10.8.0)

Commands are suggestions: review each one before running it.

Loading voting…