OpenClaw: Exec environment denylist missed high-risk interpreter startup variables
CVE-2026-43584GHSA-vfp4-8x56-j7c5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.4.10
- Fixed in
- 2026.4.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vfp4-8x56-j7c5 lists affected ranges: npm openclaw >=0 <2026.4.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfp4-8x56-j7c5 lists affected ranges: npm openclaw >=0 <2026.4.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-43584: 0.39% estimated exploitation activity in the next 30 days; percentile 33.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Exec environment denylist missed high-risk interpreter startup variables. Affected Packages / Versions - Package: openclaw - Ecosystem: npm - Affected versions: < 2026.4.10 - Patched versions: = 2026.4.10 Impact The exec environment policy missed interpreter startup variables such as VIMINIT, EXINIT, LUAINIT, and HOSTALIASES, allowing operator-supplied environment overrides to influence downstream execution or network behavior. Technical Details The fix expands the host environment security policy denylist to cover these and related high-risk environment variables, with regression coverage. Fix The issue was fixed in #63277. The first stable tag containing the fix is v2026.4.10, and openclaw@2026.4.14 includes the fix. Fix Commit(s) - 2d126fc62343a7b6895351f96e4e1474bc358140 - PR: #63277 Release Process Note Users should upgrade to openclaw 2026.4.10 or newer. The latest npm release, 2026.4.14, already includes the fix. Credits Thanks to @feiyang666 of Tencent zhuque Lab…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vfp4-8x56-j7c5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vfp4-8x56-j7c5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43584 Advisory: OpenClaw: Exec environment denylist missed high-risk interpreter startup variables IDs: CVE-2026-43584, GHSA-vfp4-8x56-j7c5 Record: https://patchnext.com/advisories/cve-2026-43584 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.4.10; fixed in 2026.4.10 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vfp4-8x56-j7c5 (OSV record GHSA-vfp4-8x56-j7c5 lists affected ranges: npm openclaw >=0 <2026.4.10 (fixed)) - Verified: https://github.com/advisories/GHSA-vfp4-8x56-j7c5 (GitHub-reviewed advisory GHSA-vfp4-8x56-j7c5 lists affected ranges: npm openclaw >=0 <2026.4.10) Commands are suggestions: review each one before running it.
Loading voting…