OpenClaw: Sandbox noVNC helper route exposed interactive browser session credentials
CVE-2026-43575GHSA-92jp-89mq-4374
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- >= 2026.2.21, < 2026.4.10
- Fixed in
- 2026.4.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-92jp-89mq-4374 lists affected ranges: npm openclaw >=2026.2.21 <2026.4.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-92jp-89mq-4374 lists affected ranges: npm openclaw >=2026.2.21 <2026.4.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-43575: 0.40% estimated exploitation activity in the next 30 days; percentile 34.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Sandbox noVNC helper route exposed interactive browser session credentials. Affected Packages / Versions - Package: openclaw - Ecosystem: npm - Affected versions: = 2026.2.21 < 2026.4.10 - Patched versions: = 2026.4.10 Impact The sandbox noVNC helper route could be reached without the intended bridge authentication, exposing an interactive browser session surface. Technical Details The fix gates the sandbox noVNC helper route behind bridge authentication. Fix The issue was fixed in #63882. The first stable tag containing the fix is v2026.4.10, and openclaw@2026.4.14 includes the fix. Fix Commit(s) - 8dfbf3268bd224b7377d1ecca77a445100746085 - PR: #63882 Release Process Note Users should upgrade to openclaw 2026.4.10 or newer. The latest npm release, 2026.4.14, already includes the fix. Credits Thanks to @zsxsoft, with sponsorship from @KeenSecurityLab and @qclawer for reporting this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-92jp-89mq-4374
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-92jp-89mq-4374
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43575 Advisory: OpenClaw: Sandbox noVNC helper route exposed interactive browser session credentials IDs: CVE-2026-43575, GHSA-92jp-89mq-4374 Record: https://patchnext.com/advisories/cve-2026-43575 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected >= 2026.2.21, < 2026.4.10; fixed in 2026.4.10 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-92jp-89mq-4374 (OSV record GHSA-92jp-89mq-4374 lists affected ranges: npm openclaw >=2026.2.21 <2026.4.10 (fixed)) - Verified: https://github.com/advisories/GHSA-92jp-89mq-4374 (GitHub-reviewed advisory GHSA-92jp-89mq-4374 lists affected ranges: npm openclaw >=2026.2.21 <2026.4.10) Commands are suggestions: review each one before running it.
Loading voting…