Skip to content

← Actionable
Medium, CVSS 4.9amended

OpenClaw: Memory dreaming config persistence was reachable from operator.write commands

CVE-2026-43568GHSA-5gjc-grvm-m88j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    >= 2026.4.5, < 2026.4.10
    Fixed in
    2026.4.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-43568: 0.21% estimated exploitation activity in the next 30 days; percentile 11.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Memory dreaming config persistence was reachable from operator.write commands. Affected Packages / Versions - Package: openclaw - Ecosystem: npm - Affected versions: = 2026.4.5 < 2026.4.10 - Patched versions: = 2026.4.10 Impact A write-scoped gateway path could toggle persistent memory dreaming settings through /dreaming, crossing into an admin-class configuration mutation. Technical Details The fix requires admin scope for persistent dreaming gateway toggles. Fix The issue was fixed in #63872. The first stable tag containing the fix is v2026.4.10, and openclaw@2026.4.14 includes the fix. Fix Commit(s) - 6af17b39e11f5f35e23b7e5a5f71a7d0aa3c7310 - PR: #63872 Release Process Note Users should upgrade to openclaw 2026.4.10 or newer. The latest npm release, 2026.4.14, already includes the fix. Credits Thanks to @zpbrent and @zsxsoft, with sponsorship from @KeenSecurityLab and @qclawer for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5gjc-grvm-m88j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5gjc-grvm-m88j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-43568

Advisory: OpenClaw: Memory dreaming config persistence was reachable from operator.write commands
IDs: CVE-2026-43568, GHSA-5gjc-grvm-m88j
Record: https://patchnext.com/advisories/cve-2026-43568 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected >= 2026.4.5, < 2026.4.10; fixed in 2026.4.10

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5gjc-grvm-m88j (OSV record GHSA-5gjc-grvm-m88j lists affected ranges: npm openclaw >=2026.4.5 <2026.4.10 (fixed))
- Verified: https://github.com/advisories/GHSA-5gjc-grvm-m88j (GitHub-reviewed advisory GHSA-5gjc-grvm-m88j lists affected ranges: npm openclaw >=2026.4.5 <2026.4.10)

Commands are suggestions: review each one before running it.

Loading voting…