Skip to content

← Actionable
Medium, CVSS 6.6amended

OpenClaw: Agent hook events could enqueue trusted system events from unsanitized external input

CVE-2026-43534GHSA-7g8c-cfr3-vqqr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.4.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.4.10
    Fixed in
    2026.4.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-43534: 0.19% estimated exploitation activity in the next 30 days; percentile 8.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Agent hook events could enqueue trusted system events from unsanitized external input. Affected Packages / Versions - Package: openclaw - Ecosystem: npm - Affected versions: < 2026.4.10 - Patched versions: = 2026.4.10 Impact Agent hook dispatch could turn externally supplied hook metadata into trusted system events, allowing untrusted input to enter the agent as higher-trust context. Technical Details The fix sanitizes hook names and marks agent hook system events as untrusted before enqueueing them. Fix The issue was fixed in #64372. The first stable tag containing the fix is v2026.4.10, and openclaw@2026.4.14 includes the fix. Fix Commit(s) - e3a845bde5b54f4f1e742d0a51ba9860f9619b29 - PR: #64372 Release Process Note Users should upgrade to openclaw 2026.4.10 or newer. The latest npm release, 2026.4.14, already includes the fix. Credits Thanks to @zsxsoft, with sponsorship from @KeenSecurityLab and @qclawer for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7g8c-cfr3-vqqr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7g8c-cfr3-vqqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-43534

Advisory: OpenClaw: Agent hook events could enqueue trusted system events from unsanitized external input
IDs: CVE-2026-43534, GHSA-7g8c-cfr3-vqqr
Record: https://patchnext.com/advisories/cve-2026-43534 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.4.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.4.10; fixed in 2026.4.10

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7g8c-cfr3-vqqr (OSV record GHSA-7g8c-cfr3-vqqr lists affected ranges: npm openclaw >=0 <2026.4.10 (fixed))
- Verified: https://github.com/advisories/GHSA-7g8c-cfr3-vqqr (GitHub-reviewed advisory GHSA-7g8c-cfr3-vqqr lists affected ranges: npm openclaw >=0 <2026.4.10)

Commands are suggestions: review each one before running it.

Loading voting…