Skip to content

← Actionable
Critical, CVSS 9.1

Apache Tomcat - Security constraints not correctly applied

CVE-2026-43515GHSA-5m62-pw8w-7w9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-catalina 11.0.22, 10.1.55, 9.0.118; org.apache.tomcat.embed:tomcat-embed-core 11.0.22, 10.1.55, 9.0.118; org.apache.tomcat:tomcat 11.0.22, 10.1.55, 9.0.118), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-5m62-pw8w-7w9f lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=0 =10.1.0-M1 =11.0.0-M1 =0 =10.1.0-M1 =11.0.0-M1 =0 =10.1.0-M1 =11.0.0-M1 <11.0.22

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-43515: 1.22% estimated exploitation activity in the next 30 days; percentile 68.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions Affected: Apache Tomcat 11.0.0-M1 to 11.0.21 Apache Tomcat 10.1.0-M1 to 10.1.54 Apache Tomcat 9.0.0.M1 to 9.0.117 Older, unsupported versions may also be affected Description: When multiple security constraints defined an HTTP method constraint for the same extension pattern, only the first method constraint was applied. Mitigation: Users of the affected versions should apply one of the following mitigations: - Upgrade to Apache Tomcat 11.0.22 or later - Upgrade to Apache Tomcat 10.1.55 or later - Upgrade to Apache Tomcat 9.0.118 or later

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5m62-pw8w-7w9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-43515

Advisory: Apache Tomcat - Security constraints not correctly applied
IDs: CVE-2026-43515, GHSA-5m62-pw8w-7w9f
Record: https://patchnext.com/advisories/cve-2026-43515 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.22, 10.1.55, 9.0.118; org.apache.tomcat.embed:tomcat-embed-core 11.0.22, 10.1.55, 9.0.118; org.apache.tomcat:tomcat 11.0.22, 10.1.55, 9.0.118. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-catalina: affected < 9.0.118; >= 10.1.0-M1, < 10.1.55; >= 11.0.0-M1, < 11.0.22; fixed in 10.1.55, 9.0.118, 11.0.22
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected < 9.0.118; >= 10.1.0-M1, < 10.1.55; >= 11.0.0-M1, < 11.0.22; fixed in 10.1.55, 9.0.118, 11.0.22
- Maven org.apache.tomcat:tomcat: affected < 9.0.118; >= 10.1.0-M1, < 10.1.55; >= 11.0.0-M1, < 11.0.22; fixed in 10.1.55, 9.0.118, 11.0.22

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5m62-pw8w-7w9f (GitHub-reviewed advisory GHSA-5m62-pw8w-7w9f lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=0 =10.1.0-M1 =11.0.0-M1 =0 =10.1.0-M1 =11.0.0-M1 =0 =10.1.0-M1 =11.0.0-M1 <11.0.22)

Commands are suggestions: review each one before running it.

Loading voting…