Skip to content

← Actionable
High, CVSS 8.8

ingress-nginx comment-based nginx configuration injection

CVE-2026-4342GHSA-f53h-mxv9-cp98

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/ingress-nginx 0.0.0-20260319175635-5183b7d86137), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/ingress-nginx

    Affected
    < 0.0.0-20260319175635-5183b7d86137
    Fixed in
    0.0.0-20260319175635-5183b7d86137

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-4342: 1.45% estimated exploitation activity in the next 30 days; percentile 73.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security issue was discovered in ingress-nginx where a combination of Ingress annotations can be used to inject configuration into nginx. This can lead to arbitrary code execution in the context of the ingress-nginx controller, and disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f53h-mxv9-cp98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-4342

Advisory: ingress-nginx comment-based nginx configuration injection
IDs: CVE-2026-4342, GHSA-f53h-mxv9-cp98
Record: https://patchnext.com/advisories/cve-2026-4342 (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/ingress-nginx 0.0.0-20260319175635-5183b7d86137. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/ingress-nginx: affected < 0.0.0-20260319175635-5183b7d86137; fixed in 0.0.0-20260319175635-5183b7d86137

## Suggested inspection (read-only)
- Go k8s.io/ingress-nginx: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/ingress-nginx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f53h-mxv9-cp98 (GitHub-reviewed advisory GHSA-f53h-mxv9-cp98 lists affected ranges: Go k8s.io/ingress-nginx >=0 <0.0.0-20260319175635-5183b7d86137)

Commands are suggestions: review each one before running it.

Loading voting…