OpenStack Ironic Python Agent Includes Functionality from Untrusted Control Sphere
CVE-2026-43003GHSA-rmxr-45gj-889w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ironic-python-agent 11.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ironic-python-agent
- Affected
- >= 1.0.0, <= 11.5.0
- Fixed in
- 11.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rmxr-45gj-889w lists affected ranges: PyPI ironic-python-agent >=1.0.0 <11.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rmxr-45gj-889w lists affected ranges: PyPI ironic-python-agent >=1.0.0 <=11.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-43003: 0.98% estimated exploitation activity in the next 30 days; percentile 62.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenStack ironic-python-agent 1.0.0 through 11.5.0. Ironic Python Agent (IPA) sometimes executes grub-install from within a chroot of the deployed partition image, leading to code execution in the case of a malicious image.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rmxr-45gj-889w
- Revision 1 · created ·
Published from osv record GHSA-rmxr-45gj-889w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43003 Advisory: OpenStack Ironic Python Agent Includes Functionality from Untrusted Control Sphere IDs: CVE-2026-43003, GHSA-rmxr-45gj-889w Record: https://patchnext.com/advisories/cve-2026-43003 (revision 2, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ironic-python-agent 11.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ironic-python-agent: affected >= 1.0.0, <= 11.5.0; fixed in 11.6.0 ## Suggested inspection (read-only) - `python -m pip show ironic-python-agent`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ironic-python-agent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rmxr-45gj-889w (OSV record GHSA-rmxr-45gj-889w lists affected ranges: PyPI ironic-python-agent >=1.0.0 <11.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rmxr-45gj-889w (GitHub-reviewed advisory GHSA-rmxr-45gj-889w lists affected ranges: PyPI ironic-python-agent >=1.0.0 <=11.5.0) Commands are suggestions: review each one before running it.
Loading voting…