OpenStack Keystone has an Authorization Bypass
CVE-2026-42999GHSA-2r23-2g6v-2m5f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 29.0.2, 28.0.2, 27.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keystone
- Affected
- >= 14.0.0, < 27.0.2>= 28.0.0, < 28.0.2>= 29.0.0, < 29.0.2
- Fixed in
- 27.0.2, 28.0.2, 29.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2r23-2g6v-2m5f lists affected ranges: PyPI keystone >=14.0.0 =28.0.0 =29.0.0 <29.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2r23-2g6v-2m5f lists affected ranges: PyPI keystone >=14.0.0 =28.0.0 =29.0.0 <29.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L
- EPSS
- CVE-2026-42999: 0.33% estimated exploitation activity in the next 30 days; percentile 26.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenStack Keystone before 29.0.2. The Keystone RBAC policy enforcer in enforcecall unconditionally merges the raw JSON request body into the policy enforcement dictionary via policydict.update(jsoninput.copy()), overwriting trusted target data that was previously set from database lookups. Because flask.request.getjson is called with force=True, this works regardless of Content-Type or HTTP method. Any authenticated user can inject arbitrary policy target attributes (e.g., userid, projectid) into the request body to bypass RBAC checks and perform unauthorized operations on resources belonging to other users or projects. This was introduced in commit 5ea59f52 (Rocky/14.0.0).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2r23-2g6v-2m5f
- Revision 1 · created ·
Published from osv record GHSA-2r23-2g6v-2m5f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42999 Advisory: OpenStack Keystone has an Authorization Bypass IDs: CVE-2026-42999, GHSA-2r23-2g6v-2m5f Record: https://patchnext.com/advisories/cve-2026-42999 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keystone 29.0.2, 28.0.2, 27.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keystone: affected >= 14.0.0, < 27.0.2; >= 28.0.0, < 28.0.2; >= 29.0.0, < 29.0.2; fixed in 27.0.2, 28.0.2, 29.0.2 ## Suggested inspection (read-only) - `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keystone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2r23-2g6v-2m5f (OSV record GHSA-2r23-2g6v-2m5f lists affected ranges: PyPI keystone >=14.0.0 =28.0.0 =29.0.0 <29.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2r23-2g6v-2m5f (GitHub-reviewed advisory GHSA-2r23-2g6v-2m5f lists affected ranges: PyPI keystone >=14.0.0 =28.0.0 =29.0.0 <29.0.2) Commands are suggestions: review each one before running it.
Loading voting…