OpenStack Ironic has an Incorrect Resource Transfer Between Spheres
CVE-2026-42997GHSA-54w4-233h-x86g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ironic-python-agent 35.0.1, 32.0.1, 29.0.5, 26.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ironic-python-agent
- Affected
- >= 33.0.0, < 35.0.1>= 30.0.0, < 32.0.1>= 27.0.0, < 29.0.5< 26.1.6
- Fixed in
- 26.1.6, 35.0.1, 29.0.5, 32.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-54w4-233h-x86g lists affected ranges: PyPI ironic-python-agent >=33.0.0 =30.0.0 =27.0.0 =0 <26.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-54w4-233h-x86g lists affected ranges: PyPI ironic-python-agent >=33.0.0 =30.0.0 =27.0.0 =0 <26.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-42997: 0.43% estimated exploitation activity in the next 30 days; percentile 37.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in idrac in OpenStack Ironic before 35.0.1. During import, a user invoking molds can request authorization to be sent to a remote endpoint. The credential forwarded is a time-limited Keystone token (which provides access to all OpenStack services Ironic is authorized for); or basic credentials configured for molds storage. The fixed versions are 26.1.6, 29.0.5, 32.0.1, and 35.0.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-54w4-233h-x86g
- Revision 1 · created ·
Published from osv record GHSA-54w4-233h-x86g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42997 Advisory: OpenStack Ironic has an Incorrect Resource Transfer Between Spheres IDs: CVE-2026-42997, GHSA-54w4-233h-x86g Record: https://patchnext.com/advisories/cve-2026-42997 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ironic-python-agent 35.0.1, 32.0.1, 29.0.5, 26.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ironic-python-agent: affected >= 33.0.0, < 35.0.1; >= 30.0.0, < 32.0.1; >= 27.0.0, < 29.0.5; < 26.1.6; fixed in 26.1.6, 35.0.1, 29.0.5, 32.0.1 ## Suggested inspection (read-only) - `python -m pip show ironic-python-agent`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ironic-python-agent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-54w4-233h-x86g (OSV record GHSA-54w4-233h-x86g lists affected ranges: PyPI ironic-python-agent >=33.0.0 =30.0.0 =27.0.0 =0 <26.1.6 (fixed)) - Verified: https://github.com/advisories/GHSA-54w4-233h-x86g (GitHub-reviewed advisory GHSA-54w4-233h-x86g lists affected ranges: PyPI ironic-python-agent >=33.0.0 =30.0.0 =27.0.0 =0 <26.1.6) Commands are suggestions: review each one before running it.
Loading voting…