ExternalSecrets vulnerable to privilege escalation with secret overwriting
CVE-2026-42876GHSA-fq7h-9x26-6j22
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/external-secrets/external-secrets/apis 2.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/external-secrets/external-secrets/apis
- Affected
- >= 0.1.0, < 2.4.1
- Fixed in
- 2.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fq7h-9x26-6j22 lists affected ranges: Go github.com/external-secrets/external-secrets/apis >=0.1.0 <2.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-42876: 0.21% estimated exploitation activity in the next 30 days; percentile 11.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ExternalSecrets allows users to craft Service Account tokens for misconfigured Service Accounts in namespaces the users have access to. Impact A user who only has permission to create ExternalSecret resources can cause the operator to create a Secret that Kubernetes will automatically populate with a long-lived token for the sepcified service account. This effectively allows the user to impersonate any service account in the namespace without needing direct create permissions on TokenRequest or Secrets of that type. The problem is mitigated in severity by the fact that the user must have pre-existing permissions already at almost the same level as the escalation later gives. The attacker cannot use this method to gain access to more information without other things also being misconfigured in the ESO installation. Patches Disallow this combination including the bootstrap token secret type. Workarounds Add admission control logic to prevent the use of Templates targeting undesired…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fq7h-9x26-6j22
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42876 Advisory: ExternalSecrets vulnerable to privilege escalation with secret overwriting IDs: CVE-2026-42876, GHSA-fq7h-9x26-6j22 Record: https://patchnext.com/advisories/cve-2026-42876 (revision 1, source checked 26 Oct 2026, 15:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/external-secrets/external-secrets/apis 2.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/external-secrets/external-secrets/apis: affected >= 0.1.0, < 2.4.1; fixed in 2.4.1 ## Suggested inspection (read-only) - Go github.com/external-secrets/external-secrets/apis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/external-secrets/external-secrets/apis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fq7h-9x26-6j22 (GitHub-reviewed advisory GHSA-fq7h-9x26-6j22 lists affected ranges: Go github.com/external-secrets/external-secrets/apis >=0.1.0 <2.4.1) Commands are suggestions: review each one before running it.
Loading voting…