Skip to content

← Actionable
High, CVSS 7.6amended

FlowiseAI has Mass Assignment in Chatflow Update Endpoint that Allows Cross-Workspace AgentFlow Reassignment

CVE-2026-42863GHSA-5wxp-qjgq-fx6m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.1.1
    Fixed in
    3.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-42863: 0.32% estimated exploitation activity in the next 30 days; percentile 24.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Mass Assignment vulnerability exists in the chatflow update endpoint of FlowiseAI. The endpoint allows clients to modify server-controlled properties such as deployed, isPublic, workspaceId, createdDate, and updatedDate when updating a chatflow object. Due to missing server-side validation and authorization checks, an authenticated user can manipulate internal attributes of a chatflow and reassign it to another workspace. This allows cross-workspace resource reassignment and unauthorized modification of deployment and visibility settings. Details The endpoint responsible for updating chatflows: PUT /api/v1/chatflows/{chatflowId} accepts a JSON request body containing the chatflow configuration (flowData) along with other metadata fields. However, the server does not restrict which properties may be modified by the client. As a result, user-controlled request bodies can include additional fields that should normally be controlled only by the backend. Examples of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5wxp-qjgq-fx6m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5wxp-qjgq-fx6m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42863

Advisory: FlowiseAI has Mass Assignment in Chatflow Update Endpoint that Allows Cross-Workspace AgentFlow Reassignment
IDs: CVE-2026-42863, GHSA-5wxp-qjgq-fx6m
Record: https://patchnext.com/advisories/cve-2026-42863 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.1.1; fixed in 3.1.2

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5wxp-qjgq-fx6m (OSV record GHSA-5wxp-qjgq-fx6m lists affected ranges: npm flowise >=0 <3.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5wxp-qjgq-fx6m (GitHub-reviewed advisory GHSA-5wxp-qjgq-fx6m lists affected ranges: npm flowise >=0 <=3.1.1)

Commands are suggestions: review each one before running it.

Loading voting…