Skip to content

← Actionable
High, CVSS 8.5amended

edx-enterprise has SSRF via SAML metadata URL in sync_provider_data endpoint

CVE-2026-42860GHSA-64cv-vxpr-j6vc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (edx-enterprise 7.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-42860: 0.30% estimated exploitation activity in the next 30 days; percentile 22.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The syncproviderdata endpoint in SAMLProviderDataViewSet fetches SAML metadata from a URL stored in SAMLProviderConfig.metadatasource. An authenticated user with the Enterprise Admin role can set this field to an arbitrary URL via the SAMLProviderConfigViewSet PATCH endpoint, then trigger a server-side HTTP request by calling syncproviderdata. The fetch in fetchmetadataxml() passes the URL directly to requests.get() with no scheme enforcement, IP filtering, or timeout. This vulnerability was introduced when the SAML admin viewsets were migrated from openedx-platform into edx-enterprise. A related fix for the equivalent fetch path in openedx-platform (the fetchsamlmetadata Celery task) was applied in GHSA-328g-7h4g-r2m9. Details Vulnerable code path: enterprise/api/v1/views/samlutils.py: enterprise/api/v1/views/samlproviderdata.py: Missing protections: - No HTTPS enforcement (HTTP is allowed; the warning is not enforced) - No blocking of loopback (127.0.0.0/8) or link-local…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-64cv-vxpr-j6vc

  2. Revision 1 · created ·

    Published from osv record GHSA-64cv-vxpr-j6vc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42860

Advisory: edx-enterprise has SSRF via SAML metadata URL in sync_provider_data endpoint
IDs: CVE-2026-42860, GHSA-64cv-vxpr-j6vc
Record: https://patchnext.com/advisories/cve-2026-42860 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: edx-enterprise 7.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI edx-enterprise: affected >= 7.0.2, <= 7.0.4; fixed in 7.0.5

## Suggested inspection (read-only)
- `python -m pip show edx-enterprise`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on edx-enterprise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-64cv-vxpr-j6vc (OSV record GHSA-64cv-vxpr-j6vc lists affected ranges: PyPI edx-enterprise >=7.0.2 <7.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-64cv-vxpr-j6vc (GitHub-reviewed advisory GHSA-64cv-vxpr-j6vc lists affected ranges: PyPI edx-enterprise >=7.0.2 <=7.0.4)

Commands are suggestions: review each one before running it.

Loading voting…