Skip to content

← Actionable
High, CVSS 8.7amended

Network-AI missing authentication on MCP HTTP endpoint, which allows unauthenticated privileged tool calls

CVE-2026-42856GHSA-fj4g-2p96-q6m3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (network-ai 5.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-42856: 0.55% estimated exploitation activity in the next 30 days; percentile 46.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory: Missing Authentication for Critical Function in Jovancoding/Network-AI | Field | Value | |---|---| | Project | Jovancoding/Network-AI | | Repository | https://github.com/Jovancoding/Network-AI | | Affected commit | c344f2053eb0d49395988f803bf92f2a86b2a0d0 | | Affected tested version | 5.1.2 | | Vulnerability type | CWE-306: Missing Authentication for Critical Function | | Severity | High | | Authentication required | None | | Default network exposure | Bind address 0.0.0.0 | | Reporter validation date | 2026-04-21 | Summary The MCP HTTP transport accepts JSON-RPC tools/call requests with no authentication, session, origin, or token check, and dispatches them directly to the orchestrator's tool registry. The default bind address is 0.0.0.0. As a result, any party with network reachability to the service can enumerate and invoke privileged management tools — including reading and mutating the live orchestrator configuration, listing registered agents, dispatching…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fj4g-2p96-q6m3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fj4g-2p96-q6m3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42856

Advisory: Network-AI missing authentication on MCP HTTP endpoint, which allows unauthenticated privileged tool calls
IDs: CVE-2026-42856, GHSA-fj4g-2p96-q6m3
Record: https://patchnext.com/advisories/cve-2026-42856 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: network-ai 5.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm network-ai: affected <= 5.1.2; fixed in 5.1.3

## Suggested inspection (read-only)
- `npm ls network-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on network-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fj4g-2p96-q6m3 (OSV record GHSA-fj4g-2p96-q6m3 lists affected ranges: npm network-ai >=0 <5.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-fj4g-2p96-q6m3 (GitHub-reviewed advisory GHSA-fj4g-2p96-q6m3 lists affected ranges: npm network-ai >=0 <=5.1.2)

Commands are suggestions: review each one before running it.

Loading voting…