Grav Vulnerable to XSS via Taxonomy Field Values in Admin Panel
CVE-2026-42842GHSA-c2q3-p4jr-c55f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.0-beta.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 2.0.0-beta.2
- Fixed in
- 2.0.0-beta.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c2q3-p4jr-c55f lists affected ranges: Packagist getgrav/grav >=0 <2.0.0-beta.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-42842: 0.18% estimated exploitation activity in the next 30 days; percentile 7.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Stored Cross-Site Scripting (XSS) vulnerability exists in the Grav CMS Form plugin's select field template. Taxonomy tag and category values are rendered with the Twig |raw filter in the admin panel, bypassing the global autoescape protection. An editor-level user can inject arbitrary JavaScript that executes in any administrator's browser session when they view or edit any page in the admin panel. Additionally, Grav's built-in XSS detection (Security::detectXss()) can be bypassed by using payloads that close the <option/<select context and use unquoted event handlers - the onevents regex fails to match event handlers without quotes or trailing spaces before . Important - The vulnerability is in the Form plugin (select.html.twig), which is installed by default with Grav - The XSS is cross-page: a malicious taxonomy value on one page executes when an admin edits any page, because taxonomy options are rendered from a shared global pool - An editor can exploit this without any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c2q3-p4jr-c55f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42842 Advisory: Grav Vulnerable to XSS via Taxonomy Field Values in Admin Panel IDs: CVE-2026-42842, GHSA-c2q3-p4jr-c55f Record: https://patchnext.com/advisories/cve-2026-42842 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.0-beta.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 2.0.0-beta.2; fixed in 2.0.0-beta.2 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c2q3-p4jr-c55f (GitHub-reviewed advisory GHSA-c2q3-p4jr-c55f lists affected ranges: Packagist getgrav/grav >=0 <2.0.0-beta.2) Commands are suggestions: review each one before running it.
Loading voting…