Apache Polaris has an Improper Input Validation issue
CVE-2026-42812GHSA-w76p-3cgp-qfcm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.polaris:polaris-runtime-service 1.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.polaris:polaris-runtime-service
- Affected
- >= 0.9.0, < 1.4.1
- Fixed in
- 1.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w76p-3cgp-qfcm lists affected ranges: Maven org.apache.polaris:polaris-runtime-service >=0.9.0 <1.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-42812: 0.36% estimated exploitation activity in the next 30 days; percentile 30.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Iceberg, the table's metadata files are control files: they tell readers which data files belong to the table and which table version to read. write.metadata.path is an optional table property that tells Polaris where to write those metadata files. For a table already registered in a Polaris-managed catalog, changing only that property through an ALTER TABLE-style settings change (not a row-level INSERT, SELECT, UPDATE, or DELETE) bypasses the commit-time branch that is supposed to revalidate storage locations. The full persisted / credential-vending variant requires the affected catalog to have polaris.config.allow.unstructured.table.location=true, with allowedLocations broad enough to include the attacker-chosen target. allowedLocations is the admin-configured allowlist of storage paths that the catalog is allowed to use. Public project materials suggest that this flag is a real supported compatibility / layout mode, not just a contrived lab-only prerequisite. In that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w76p-3cgp-qfcm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42812 Advisory: Apache Polaris has an Improper Input Validation issue IDs: CVE-2026-42812, GHSA-w76p-3cgp-qfcm Record: https://patchnext.com/advisories/cve-2026-42812 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.polaris:polaris-runtime-service 1.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.polaris:polaris-runtime-service: affected >= 0.9.0, < 1.4.1; fixed in 1.4.1 ## Suggested inspection (read-only) - Maven org.apache.polaris:polaris-runtime-service: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.polaris:polaris-runtime-service. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w76p-3cgp-qfcm (GitHub-reviewed advisory GHSA-w76p-3cgp-qfcm lists affected ranges: Maven org.apache.polaris:polaris-runtime-service >=0.9.0 <1.4.1) Commands are suggestions: review each one before running it.
Loading voting…