The Query Monitor plugin for WordPress has Reflected Cross-Site Scripting via Request URI
CVE-2026-4267GHSA-2xr4-chcf-vmvf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (johnbillion/query-monitor 3.20.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist johnbillion/query-monitor
- Affected
- < 3.20.4
- Fixed in
- 3.20.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2xr4-chcf-vmvf lists affected ranges: Packagist johnbillion/query-monitor >=0 <3.20.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-4267: 0.31% estimated exploitation activity in the next 30 days; percentile 23.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Query Monitor plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the $SERVER['REQUESTURI'] parameter in all versions up to, and including, 3.20.3 due to insufficient output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick an Administrator-level user into performing an action such as clicking on a link. On admin requests, the plugin reads user controlled data from $SERVER['REQUESTURI'] and stores it in the request field, then renders request, matchedquery, and querystring through formaturl(). If the attacker supplied string does not contain &, formaturl() returns it without HTML escaping, which allows injected HTML or JavaScript from the request target to be inserted directly into the page inside a <code element and executed in the victim's browser. Patches This issue has been patched in Query Monitor 3.20.4. Credits Many thanks to Dmitrii Ignatyev at…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2xr4-chcf-vmvf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-4267 Advisory: The Query Monitor plugin for WordPress has Reflected Cross-Site Scripting via Request URI IDs: CVE-2026-4267, GHSA-2xr4-chcf-vmvf Record: https://patchnext.com/advisories/cve-2026-4267 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: johnbillion/query-monitor 3.20.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist johnbillion/query-monitor: affected < 3.20.4; fixed in 3.20.4 ## Suggested inspection (read-only) - Packagist johnbillion/query-monitor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on johnbillion/query-monitor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2xr4-chcf-vmvf (GitHub-reviewed advisory GHSA-2xr4-chcf-vmvf lists affected ranges: Packagist johnbillion/query-monitor >=0 <3.20.4) Commands are suggestions: review each one before running it.
Loading voting…