Svelte SSR vulnerable to cross-site scripting via spread attributes
CVE-2026-42599GHSA-pr6f-5x2q-rwfp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (svelte 5.55.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm svelte
- Affected
- <= 5.55.6
- Fixed in
- 5.55.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pr6f-5x2q-rwfp lists affected ranges: npm svelte >=0 <5.55.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pr6f-5x2q-rwfp lists affected ranges: npm svelte >=0 <=5.55.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2026-42599: 0.21% estimated exploitation activity in the next 30 days; percentile 10.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. Note that this vulnerability only triggers if the user's browser has JavaScript enabled but Svelte's hydration mechanism does not reach the vulnerable element before the event fires. This is similar to but different from CVE-2026-27121.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pr6f-5x2q-rwfp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pr6f-5x2q-rwfp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42599 Advisory: Svelte SSR vulnerable to cross-site scripting via spread attributes IDs: CVE-2026-42599, GHSA-pr6f-5x2q-rwfp Record: https://patchnext.com/advisories/cve-2026-42599 (revision 3, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: svelte 5.55.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm svelte: affected <= 5.55.6; fixed in 5.55.7 ## Suggested inspection (read-only) - `npm ls svelte --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on svelte. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pr6f-5x2q-rwfp (OSV record GHSA-pr6f-5x2q-rwfp lists affected ranges: npm svelte >=0 <5.55.7 (fixed)) - Verified: https://github.com/advisories/GHSA-pr6f-5x2q-rwfp (GitHub-reviewed advisory GHSA-pr6f-5x2q-rwfp lists affected ranges: npm svelte >=0 <=5.55.6) Commands are suggestions: review each one before running it.
Loading voting…