Gotenberg vulnerable to unauthenticated SSRF via default deny-list bypass in downloadFrom and webhook
CVE-2026-42596GHSA-4vmc-gm8v-m35h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gotenberg/gotenberg/v8 8.32.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/gotenberg/gotenberg/v8
- Affected
- <= 8.30.1
- Fixed in
- 8.32.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4vmc-gm8v-m35h lists affected ranges: Go github.com/gotenberg/gotenberg/v8 >=0 <=8.30.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2026-42596: 1.59% estimated exploitation activity in the next 30 days; percentile 75.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The default deny-lists used by Gotenberg's downloadFrom feature and webhook feature are bypassable. Because the filter is regex-based and case-sensitive, an unauthenticated attacker can supply URLs such as http://[::ffff:127.0.0.1]:... and reach loopback or private HTTP services that the default deny-list is intended to block. This crosses a real security boundary because an external caller can force the server to make outbound requests to internal-only targets. Details The issue originates from the shipped default deny-list regexes and the way those regexes are applied: - pkg/modules/api/api.go:198-200 defines the default api-download-from-deny-list. - pkg/modules/webhook/webhook.go:41-43 defines the default webhook-deny-list. - pkg/gotenberg/filter.go:20-69 evaluates those patterns with regexp2 using case-sensitive matching. The attacker-controlled URL then reaches outbound request sinks: - pkg/modules/api/context.go:208-282 - Reads attacker-supplied downloadFrom. - Calls…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4vmc-gm8v-m35h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42596 Advisory: Gotenberg vulnerable to unauthenticated SSRF via default deny-list bypass in downloadFrom and webhook IDs: CVE-2026-42596, GHSA-4vmc-gm8v-m35h Record: https://patchnext.com/advisories/cve-2026-42596 (revision 1, source checked 26 Oct 2026, 15:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gotenberg/gotenberg/v8 8.32.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gotenberg/gotenberg/v8: affected <= 8.30.1; fixed in 8.32.0 ## Suggested inspection (read-only) - Go github.com/gotenberg/gotenberg/v8: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gotenberg/gotenberg/v8. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4vmc-gm8v-m35h (GitHub-reviewed advisory GHSA-4vmc-gm8v-m35h lists affected ranges: Go github.com/gotenberg/gotenberg/v8 >=0 <=8.30.1) Commands are suggestions: review each one before running it.
Loading voting…