Skip to content

← Actionable
High, CVSS 7.5

Netty: HttpContentDecompressor maxAllocation bypass when Content-Encoding set to br/zstd/snappy leads to decompression bomb DoS

CVE-2026-42587GHSA-f6hv-jmp6-3vwv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http2 4.2.13.Final, 4.1.133.Final; io.netty:netty-codec-http 4.2.13.Final, 4.1.133.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-42587: 0.99% estimated exploitation activity in the next 30 days; percentile 62.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary HttpContentDecompressor accepts a maxAllocation parameter to limit decompression buffer size and prevent decompression bomb attacks. This limit is correctly enforced for gzip and deflate encodings via ZlibDecoder, but is silently ignored when the content encoding is br (Brotli), zstd, or snappy. An attacker can bypass the configured decompression limit by sending a compressed payload with Content-Encoding: br instead of Content-Encoding: gzip, causing unbounded memory allocation and out-of-memory denial of service. The same vulnerability exists in DelegatingDecompressorFrameListener for HTTP/2 connections. Details HttpContentDecompressor stores the maxAllocation value at construction time (HttpContentDecompressor.java:89) and uses it in newContentDecoder() to create the appropriate decompression handler. For gzip/deflate, maxAllocation is forwarded to ZlibCodecFactory.newZlibDecoder(): ZlibDecoder.prepareDecompressBuffer() enforces this as a hard cap by setting the buffer's…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f6hv-jmp6-3vwv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42587

Advisory: Netty: HttpContentDecompressor maxAllocation bypass when Content-Encoding set to br/zstd/snappy leads to decompression bomb DoS
IDs: CVE-2026-42587, GHSA-f6hv-jmp6-3vwv
Record: https://patchnext.com/advisories/cve-2026-42587 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http2 4.2.13.Final, 4.1.133.Final; io.netty:netty-codec-http 4.2.13.Final, 4.1.133.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-codec-http2: affected >= 4.2.0.Alpha1, <= 4.2.12.Final; <= 4.1.132.Final; fixed in 4.2.13.Final, 4.1.133.Final
- Maven io.netty:netty-codec-http: affected >= 4.2.0.Alpha1, <= 4.2.12.Final; <= 4.1.132.Final; fixed in 4.2.13.Final, 4.1.133.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-codec-http2: check the installed version with your package manager.
- Maven io.netty:netty-codec-http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-codec-http2, io.netty:netty-codec-http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f6hv-jmp6-3vwv (GitHub-reviewed advisory GHSA-f6hv-jmp6-3vwv lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Alpha1 =0 =4.2.0.Alpha1 =0 <=4.1.132.Final)

Commands are suggestions: review each one before running it.

Loading voting…