Netty Redis Codec Encoder has a CRLF Injection Issue
CVE-2026-42586GHSA-rgrr-p7gp-5xj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-redis 4.2.13.Final, 4.1.133.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-redis
- Affected
- >= 4.2.0.Alpha1, <= 4.2.12.Final<= 4.1.132.Final
- Fixed in
- 4.2.13.Final, 4.1.133.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rgrr-p7gp-5xj7 lists affected ranges: Maven io.netty:netty-codec-redis >=4.2.0.Alpha1 =0 <=4.1.132.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
- EPSS
- CVE-2026-42586: 0.22% estimated exploitation activity in the next 30 days; percentile 12.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Security Vulnerability Report: CRLF Injection in Netty Redis Codec Encoder 1. Vulnerability Summary | Field | Value | |-------|-------| | Product | Netty | | Version | 4.2.12.Final (and all prior versions with codec-redis) | | Component | io.netty.handler.codec.redis.RedisEncoder | | Vulnerability Type | CWE-93: Improper Neutralization of CRLF Sequences (CRLF Injection) | | Impact | Redis Command Injection / Response Poisoning | | Attack Vector | Network | | Attack Complexity | Low | | Privileges Required | None | | User Interaction | None | | Scope | Unchanged | | Confidentiality Impact | High | | Integrity Impact | High | | Availability Impact | None | 2. Affected Components The following classes in the codec-redis module are affected: - io.netty.handler.codec.redis.RedisEncoder (encoder - no output validation) - io.netty.handler.codec.redis.InlineCommandRedisMessage (no input validation) - io.netty.handler.codec.redis.SimpleStringRedisMessage (no input validation) -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rgrr-p7gp-5xj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42586 Advisory: Netty Redis Codec Encoder has a CRLF Injection Issue IDs: CVE-2026-42586, GHSA-rgrr-p7gp-5xj7 Record: https://patchnext.com/advisories/cve-2026-42586 (revision 1, source checked 26 Oct 2026, 16:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-redis 4.2.13.Final, 4.1.133.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-redis: affected >= 4.2.0.Alpha1, <= 4.2.12.Final; <= 4.1.132.Final; fixed in 4.2.13.Final, 4.1.133.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-redis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-redis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rgrr-p7gp-5xj7 (GitHub-reviewed advisory GHSA-rgrr-p7gp-5xj7 lists affected ranges: Maven io.netty:netty-codec-redis >=4.2.0.Alpha1 =0 <=4.1.132.Final) Commands are suggestions: review each one before running it.
Loading voting…