Skip to content

← Actionable
High, CVSS 7.5

Netty HTTP/3 QPACK literal unbounded allocation

CVE-2026-42582GHSA-2c5c-chwr-9hqw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http3 4.2.13.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-42582: 0.44% estimated exploitation activity in the next 30 days; percentile 38.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When Netty decodes HTTP/3 headers, it sometimes runs new byte[length] using a length from the wire before checking that many bytes are really there. A small malicious header can claim a huge length (on the order of a gigabyte). Details When decoding header blocks, the non-Huffman branch of io.netty.handler.codec.http3.QpackDecoder#decodeHuffmanEncodedLiteral may execute new byte[length] for a string literal before verifying that length bytes are actually present in the compressed field section. The wire encoding allows a very large length to be expressed in few bytes. There is no check that length <= in.readableBytes() before new byte[length]. PoC The test below constructs a small HTTP/3 HEADERS frame whose QPACK section decodes to a ~1 GiB non-Huffman name length and is used to observe server-side failure; it illustrates how little wire data can target new byte[length]. Impact The server can slow down, stall, or crash under load when many crafted HTTP/3 HEADERS frames…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2c5c-chwr-9hqw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42582

Advisory: Netty HTTP/3 QPACK literal unbounded allocation
IDs: CVE-2026-42582, GHSA-2c5c-chwr-9hqw
Record: https://patchnext.com/advisories/cve-2026-42582 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http3 4.2.13.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-codec-http3: affected >= 4.2.0.Final, <= 4.2.12.Final; fixed in 4.2.13.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-codec-http3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-codec-http3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2c5c-chwr-9hqw (GitHub-reviewed advisory GHSA-2c5c-chwr-9hqw lists affected ranges: Maven io.netty:netty-codec-http3 >=4.2.0.Final <=4.2.12.Final)

Commands are suggestions: review each one before running it.

Loading voting…