Skip to content

← Actionable
High, CVSS 7.5amended

Svelte devalue: DoS via sparse array deserialization

CVE-2026-42570GHSA-77vg-94rm-hx3p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (devalue 5.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm devalue

    Affected
    >= 5.6.3, <= 5.8.0
    Fixed in
    5.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-42570: 0.40% estimated exploitation activity in the next 30 days; percentile 33.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-77vg-94rm-hx3p

  2. Revision 1 · created ·

    Published from osv record GHSA-77vg-94rm-hx3p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42570

Advisory: Svelte devalue: DoS via sparse array deserialization
IDs: CVE-2026-42570, GHSA-77vg-94rm-hx3p
Record: https://patchnext.com/advisories/cve-2026-42570 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: devalue 5.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm devalue: affected >= 5.6.3, <= 5.8.0; fixed in 5.8.1

## Suggested inspection (read-only)
- `npm ls devalue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on devalue.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-77vg-94rm-hx3p (OSV record GHSA-77vg-94rm-hx3p lists affected ranges: npm devalue >=5.6.3 <5.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-77vg-94rm-hx3p (GitHub-reviewed advisory GHSA-77vg-94rm-hx3p lists affected ranges: npm devalue >=5.6.3 <=5.8.0)

Commands are suggestions: review each one before running it.

Loading voting…