phpVMS has an /importer authorization bypass causing full database wipe
CVE-2026-42569GHSA-fv26-4939-62fh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nabeel/phpvms 7.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist nabeel/phpvms
- Affected
- < 7.0.6
- Fixed in
- 7.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fv26-4939-62fh lists affected ranges: Packagist nabeel/phpvms >=0 <7.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
- EPSS
- CVE-2026-42569: 1.17% estimated exploitation activity in the next 30 days; percentile 67.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Security Advisory: Unauthenticated Access to Legacy Import Feature Severity: Critical Affected versions: phpVMS 7.x (up to 7.0.5) Fixed in: v7.0.6 Component: Legacy importer Summary A critical vulnerability in phpVMS 7.x allowed unauthenticated access to a legacy import feature. Although this feature is deprecated, parts of it remained accessible and operational. Impact A remote attacker could trigger internal processes that modify or delete application data, potentially resulting in: - Data loss - Service disruption No authentication was required. Remediation - Update immediately to the latest patched version - If unable to update: - The release link has instructions on how to fix it (it's a one-line fix to comment out the routes) Affected Versions Affected: phpVMS 7.x ≤ 7.0.5 Not affected: phpVMS = 7.0.6, v8 (feature removed from public access)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fv26-4939-62fh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-42569 Advisory: phpVMS has an /importer authorization bypass causing full database wipe IDs: CVE-2026-42569, GHSA-fv26-4939-62fh Record: https://patchnext.com/advisories/cve-2026-42569 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nabeel/phpvms 7.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist nabeel/phpvms: affected < 7.0.6; fixed in 7.0.6 ## Suggested inspection (read-only) - Packagist nabeel/phpvms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nabeel/phpvms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fv26-4939-62fh (GitHub-reviewed advisory GHSA-fv26-4939-62fh lists affected ranges: Packagist nabeel/phpvms >=0 <7.0.6) Commands are suggestions: review each one before running it.
Loading voting…