Skip to content

← Actionable
High, CVSS 7.5amended

python-multipart has Denial of Service via unbounded multipart part headers

CVE-2026-42561GHSA-pp6c-gr5w-3c5g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-multipart 0.0.27), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-42561: 0.74% estimated exploitation activity in the next 30 days; percentile 54.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary python-multipart has a denial of service vulnerability in multipart part header parsing. When parsing multipart/form-data, MultipartParser previously had no limit on the number of part headers or the size of an individual part header. An attacker could send a request with either many repeated headers without terminating the header block or a single very large header value, causing excessive CPU work before request rejection or completion. Impact Applications that parse attacker-controlled multipart/form-data with affected versions of python-multipart can experience CPU exhaustion. ASGI applications using Starlette, FastAPI, or other frameworks that invoke python-multipart may have worker or event-loop delays while processing malicious upload requests. Details The affected parser states are HEADERFIELDSTART, HEADERFIELD, HEADERVALUESTART, HEADERVALUE, and HEADERVALUEALMOSTDONE. The issue can be triggered by: - A multipart part with an oversized individual header value. - A…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pp6c-gr5w-3c5g

  2. Revision 1 · created ·

    Published from osv record GHSA-pp6c-gr5w-3c5g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42561

Advisory: python-multipart has Denial of Service via unbounded multipart part headers
IDs: CVE-2026-42561, GHSA-pp6c-gr5w-3c5g
Record: https://patchnext.com/advisories/cve-2026-42561 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-multipart 0.0.27. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI python-multipart: affected < 0.0.27; fixed in 0.0.27

## Suggested inspection (read-only)
- `python -m pip show python-multipart`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-multipart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pp6c-gr5w-3c5g (OSV record GHSA-pp6c-gr5w-3c5g lists affected ranges: PyPI python-multipart >=0 <0.0.27 (fixed))
- Verified: https://github.com/advisories/GHSA-pp6c-gr5w-3c5g (GitHub-reviewed advisory GHSA-pp6c-gr5w-3c5g lists affected ranges: PyPI python-multipart >=0 <0.0.27)

Commands are suggestions: review each one before running it.

Loading voting…