Skip to content

← Actionable
High, CVSS 8.6amended

JupyterLab's command linker attributes in HTML enable one-click command execution from untrusted content

CVE-2026-42557GHSA-mqcg-5x36-vfcg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 4.5.7; notebook 7.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI jupyterlab

    Affected
    <= 4.5.6
    Fixed in
    4.5.7
  • PyPI notebook

    Affected
    >= 7.0.0, <= 7.5.5
    Fixed in
    7.5.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-42557: 0.49% estimated exploitation activity in the next 30 days; percentile 41.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

JupyterLab's HTML sanitizer allowlists data-commandlinker-command and data-commandlinker-args on button elements, while CommandLinker listens for all click events on document.body and executes the named command without checking whether the element came from trusted JupyterLab UI. A notebook with a pre-saved HTML cell output containing a deceptive button can trigger arbitrary JupyterLab commands - including arbitrary code execution - on a single user click, without any code being submitted for execution by the user. Impact An attacker who shares a notebook or a Markdown file - via email, GitHub, or a Binder link - can invoke an arbitrary command upon a single click by the victim. The button can be rendered inside the output area and be visually indistinguishable from a legitimate widget. No kernel needs to start; the HTML output is stored in the notebook file and displayed immediately on open. Single-click impact An attacker convincing the victim to click on a single button or link…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mqcg-5x36-vfcg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mqcg-5x36-vfcg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42557

Advisory: JupyterLab's command linker attributes in HTML enable one-click command execution from untrusted content
IDs: CVE-2026-42557, GHSA-mqcg-5x36-vfcg
Record: https://patchnext.com/advisories/cve-2026-42557 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlab 4.5.7; notebook 7.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlab: affected <= 4.5.6; fixed in 4.5.7
- PyPI notebook: affected >= 7.0.0, <= 7.5.5; fixed in 7.5.6

## Suggested inspection (read-only)
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlab, notebook.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mqcg-5x36-vfcg (OSV record GHSA-mqcg-5x36-vfcg lists affected ranges: PyPI jupyterlab >=0 =7.0.0 <7.5.6 (fixed))
- Verified: https://github.com/advisories/GHSA-mqcg-5x36-vfcg (GitHub-reviewed advisory GHSA-mqcg-5x36-vfcg lists affected ranges: PyPI jupyterlab >=0 =7.0.0 <=7.5.5)

Commands are suggestions: review each one before running it.

Loading voting…