Skip to content

← Actionable
High, CVSS 7.1amended

Cinny vulnerable to access token disclosure via invalidated emoji pack avatar URL in service worker

CVE-2026-42553GHSA-j944-w549-3453

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cinny 4.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm cinny

    Affected
    < 4.10.3
    Fixed in
    4.10.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-42553: 0.30% estimated exploitation activity in the next 30 days; percentile 23.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A remote authenticated attacker who shares a room with a victim and has permissions to create room emotes (for example in a DM) can cause the victim's client to send their Matrix access token to an attacker-controlled server. This occurs when the victim opens the emoji or sticker picker for the room containing a malicious emote pack. The root causes are: (1) an incorrect fallback in EmojiBoard that uses untrusted pack.meta.avatar (user-controlled) without converting/validating it as an MXC URL, allowing arbitrary HTTP(S) URLs to be used; and (2) the service worker attaching the user's Authorization bearer token to all outbound GET requests whose URL contains /matrix/client/v1/media/download or /matrix/client/v1/media/thumbnail without verifying the request host matches the configured homeserver origin. An attacker-controlled URL containing those path fragments and permissive CORS will receive the victim's Authorization header (access token). Impacted users: anybody using…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j944-w549-3453

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j944-w549-3453

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-42553

Advisory: Cinny vulnerable to access token disclosure via invalidated emoji pack avatar URL in service worker
IDs: CVE-2026-42553, GHSA-j944-w549-3453
Record: https://patchnext.com/advisories/cve-2026-42553 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cinny 4.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm cinny: affected < 4.10.3; fixed in 4.10.3

## Suggested inspection (read-only)
- `npm ls cinny --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cinny.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j944-w549-3453 (OSV record GHSA-j944-w549-3453 lists affected ranges: npm cinny >=0 <4.10.3 (fixed))
- Verified: https://github.com/advisories/GHSA-j944-w549-3453 (GitHub-reviewed advisory GHSA-j944-w549-3453 lists affected ranges: npm cinny >=0 <4.10.3)

Commands are suggestions: review each one before running it.

Loading voting…